aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index ec9bf29..82e3981 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -108,6 +108,19 @@ let
108 }; 108 };
109 }; 109 };
110 }; 110 };
111 smtpOptions = {
112 host = mkOption { description = "Host to access SMTP"; type = str; };
113 port = mkOption { description = "Port to access SMTP"; type = str; };
114 };
115 mkSmtpOptions = name: mkOption {
116 description = "${name} smtp configuration";
117 type = submodule {
118 options = smtpOptions // {
119 email = mkOption { description = "${name} email"; type = str; };
120 password = mkOption { description = "SMTP password of the ${name} user"; type = str; };
121 };
122 };
123 };
111 hostEnv = submodule { 124 hostEnv = submodule {
112 options = { 125 options = {
113 fqdn = mkOption { 126 fqdn = mkOption {
@@ -258,6 +271,10 @@ in
258 }; 271 };
259 }; 272 };
260 }; 273 };
274 smtp = mkOption {
275 type = submodule { options = smtpOptions; };
276 description = "SMTP configuration";
277 };
261 ldap = mkOption { 278 ldap = mkOption {
262 description = '' 279 description = ''
263 LDAP server configuration 280 LDAP server configuration
@@ -1051,6 +1068,16 @@ in
1051 type = attrsOf str; 1068 type = attrsOf str;
1052 description = "Mapping 'name'.php => script for webhooks"; 1069 description = "Mapping 'name'.php => script for webhooks";
1053 }; 1070 };
1071 commento = mkOption {
1072 description = "Commento configuration";
1073 type = submodule {
1074 options = {
1075 listenPort = mkOption { type = port; description = "Port to listen to"; };
1076 postgresql = mkPsqlOptions "Commento";
1077 smtp = mkSmtpOptions "Commento";
1078 };
1079 };
1080 };
1054 ympd = mkOption { 1081 ympd = mkOption {
1055 description = "Ympd configuration"; 1082 description = "Ympd configuration";
1056 type = submodule { 1083 type = submodule {