aboutsummaryrefslogtreecommitdiff
path: root/modules/private/dns.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/dns.nix')
-rw-r--r--modules/private/dns.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/private/dns.nix b/modules/private/dns.nix
index f0a3a5b..b4772fc 100644
--- a/modules/private/dns.nix
+++ b/modules/private/dns.nix
@@ -1,5 +1,6 @@
1{ lib, pkgs, config, myconfig, ... }: 1{ lib, pkgs, config, myconfig, ... }:
2{ 2{
3 options.myServices.dns.enable = lib.mkEnableOption "enable DNS resolver";
3 config = let 4 config = let
4 cfg = config.services.bind; 5 cfg = config.services.bind;
5 configFile = pkgs.writeText "named.conf" '' 6 configFile = pkgs.writeText "named.conf" ''
@@ -49,8 +50,7 @@
49 '') 50 '')
50 cfg.zones } 51 cfg.zones }
51 ''; 52 '';
52 in 53 in lib.mkIf config.myServices.dns.enable {
53 {
54 networking.firewall.allowedUDPPorts = [ 53 ]; 54 networking.firewall.allowedUDPPorts = [ 53 ];
55 networking.firewall.allowedTCPPorts = [ 53 ]; 55 networking.firewall.allowedTCPPorts = [ 53 ];
56 services.bind = { 56 services.bind = {