aboutsummaryrefslogtreecommitdiff
path: root/flakes/opendmarc/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/opendmarc/flake.nix')
-rw-r--r--flakes/opendmarc/flake.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/flakes/opendmarc/flake.nix b/flakes/opendmarc/flake.nix
index 277fd25..70b8cd7 100644
--- a/flakes/opendmarc/flake.nix
+++ b/flakes/opendmarc/flake.nix
@@ -2,9 +2,7 @@
2 description = "Open source ARC implementation"; 2 description = "Open source ARC implementation";
3 3
4 inputs.myuids = { 4 inputs.myuids = {
5 url = "https://git.immae.eu/perso/Immae/Config/Nix.git"; 5 url = "path:../myuids";
6 type = "git";
7 dir = "flakes/myuids";
8 }; 6 };
9 inputs.flake-utils.url = "github:numtide/flake-utils"; 7 inputs.flake-utils.url = "github:numtide/flake-utils";
10 inputs.nixpkgs.url = "github:NixOS/nixpkgs"; 8 inputs.nixpkgs.url = "github:NixOS/nixpkgs";
@@ -51,7 +49,9 @@
51 defaultSock = "/run/opendmarc/opendmarc.sock"; 49 defaultSock = "/run/opendmarc/opendmarc.sock";
52 args = [ "-f" "-l" "-p" "local:${cfg.socket}" ] ++ lib.optionals (cfg.configFile != null) [ "-c" cfg.configFile ]; 50 args = [ "-f" "-l" "-p" "local:${cfg.socket}" ] ++ lib.optionals (cfg.configFile != null) [ "-c" cfg.configFile ];
53 in { 51 in {
54 options = { 52 # Necessary for situations where flake gets included multiple times
53 key = builtins.hashString "sha256" (builtins.path { path = self.sourceInfo.outPath; name = "source"; });
54 options = {
55 services.opendmarc = { 55 services.opendmarc = {
56 enable = lib.mkOption { 56 enable = lib.mkOption {
57 type = lib.types.bool; 57 type = lib.types.bool;