aboutsummaryrefslogtreecommitdiff
path: root/st-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'st-git/PKGBUILD')
-rw-r--r--st-git/PKGBUILD66
1 files changed, 0 insertions, 66 deletions
diff --git a/st-git/PKGBUILD b/st-git/PKGBUILD
deleted file mode 100644
index 4a5b6b4..0000000
--- a/st-git/PKGBUILD
+++ /dev/null
@@ -1,66 +0,0 @@
1# Maintainer: mar77i <mar77i at mar77i dot ch>
2# Past Maintainer: Gaetan Bisson <bisson@archlinux.org>
3# Contributor: Scytrin dai Kinthra <scytrin@gmail.com>
4
5pkgname=st-git
6_pkgname=st
7pkgver=0.8.2.1.ge85b6b6
8pkgrel=1
9pkgdesc='Simple virtual terminal emulator for X'
10url='http://st.suckless.org/'
11arch=('i686' 'x86_64')
12license=('MIT')
13options=('zipman')
14depends=('libxft')
15makedepends=('ncurses' 'libxext' 'git')
16epoch=1
17# include config.h and any patches you want to have applied here
18source=('git://git.suckless.org/st')
19sha1sums=('SKIP')
20
21provides=("${_pkgname}")
22conflicts=("${_pkgname}")
23
24pkgver() {
25 cd "${_pkgname}"
26 git describe --tags |sed 's/-/./g'
27}
28
29prepare() {
30 local file
31 cd "${_pkgname}"
32 sed \
33 -e '/char font/s/= .*/= "Fixed:pixelsize=13:style=SemiCondensed";/' \
34 -e '/char worddelimiters/s/= .*/= " '"'"'`\\\"()[]{}<>|";/' \
35 -e '/int defaultcs/s/= .*/= 1;/' \
36 -i config.def.h
37 sed \
38 -e 's/CPPFLAGS =/CPPFLAGS +=/g' \
39 -e 's/CFLAGS =/CFLAGS +=/g' \
40 -e 's/LDFLAGS =/LDFLAGS +=/g' \
41 -e 's/_BSD_SOURCE/_DEFAULT_SOURCE/' \
42 -i config.mk
43 sed '/@tic/d' -i Makefile
44 for file in "${source[@]}"; do
45 if [[ "$file" == "config.h" ]]; then
46 # add config.h if present in source array
47 # Note: this supersedes the above sed to config.def.h
48 cp "$srcdir/$file" .
49 elif [[ "$file" == *.diff || "$file" == *.patch ]]; then
50 # add all patches present in source array
51 patch -Np1 <"$srcdir/$(basename ${file})"
52 fi
53 done
54}
55
56build() {
57 cd "${_pkgname}"
58 make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
59}
60
61package() {
62 cd "${_pkgname}"
63 make PREFIX=/usr DESTDIR="${pkgdir}" install
64 install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
65 install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
66}