diff options
Diffstat (limited to 'patacrep-git/PKGBUILD')
-rw-r--r-- | patacrep-git/PKGBUILD | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/patacrep-git/PKGBUILD b/patacrep-git/PKGBUILD new file mode 100644 index 0000000..19d0553 --- /dev/null +++ b/patacrep-git/PKGBUILD | |||
@@ -0,0 +1,31 @@ | |||
1 | # Maintainer: Immae <ismael.bouya@normalesup.org> | ||
2 | |||
3 | pkgname=patacrep-git | ||
4 | pkgver=5.1.2.r17.g30eb8d62 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="Engine for LaTeX songbooks" | ||
7 | arch=('any') | ||
8 | url="http://www.patacrep.com" | ||
9 | license=('GPL') | ||
10 | depends=('python' 'python-ply' 'python-jinja' 'python-chardet' | ||
11 | 'python-unidecode' 'texlive-fontsextra' 'texlive-latexextra' | ||
12 | 'python-argparse' 'lilypond') | ||
13 | makedepends=('python-setuptools') | ||
14 | source=("patacrep-git::git://github.com/patacrep/patacrep.git#branch=master") | ||
15 | sha256sums=('SKIP') | ||
16 | |||
17 | pkgver() { | ||
18 | cd "$srcdir/$pkgname" | ||
19 | git describe --long --tags | sed -e 's/\([^-]*-g\)/r\1/;s/-/./g' -e "s/^v//" | ||
20 | } | ||
21 | |||
22 | build() { | ||
23 | cd "$srcdir/$pkgname" | ||
24 | python setup.py build | ||
25 | } | ||
26 | |||
27 | package(){ | ||
28 | cd "$srcdir/$pkgname" | ||
29 | python setup.py install --root="${pkgdir}" | ||
30 | } | ||
31 | |||