diff options
Diffstat (limited to 'dash-static/PKGBUILD')
-rw-r--r-- | dash-static/PKGBUILD | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/dash-static/PKGBUILD b/dash-static/PKGBUILD new file mode 100644 index 0000000..9a9e1e7 --- /dev/null +++ b/dash-static/PKGBUILD | |||
@@ -0,0 +1,25 @@ | |||
1 | # Maintainer : Immae <ismael.bouya@normalesup.org> | ||
2 | |||
3 | pkgname=dash-static | ||
4 | pkgver=0.5.10.2 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="POSIX compliant shell that aims to be as small as possible. Statically compiled" | ||
7 | arch=('x86_64') | ||
8 | url="http://gondor.apana.org.au/~herbert/dash/" | ||
9 | license=('BSD') | ||
10 | source=("http://gondor.apana.org.au/~herbert/dash/files/dash-${pkgver}.tar.gz") | ||
11 | sha512sums=('0ae29be77794df0ba254967649b9728611a75fbb3acd32ab6634d76399d1ce97c7d12d31da465482a7e4f3207093415c496c39525cace9b78ab3cb9444dd7640') | ||
12 | |||
13 | |||
14 | build () { | ||
15 | cd "dash-$pkgver" | ||
16 | export CC="gcc -static" | ||
17 | export CFLAGS="-Os -static" | ||
18 | ./configure --with-libedit | ||
19 | make | ||
20 | } | ||
21 | |||
22 | package() { | ||
23 | cd "dash-$pkgver" | ||
24 | install -Dm755 src/dash $pkgdir/usr/bin/dash-static | ||
25 | } | ||