aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..cf04d63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
1# Maintainer: Ray Rashif <schiv@archlinux.org>
2
3pkgname=waon
4pkgver=0.10
5pkgrel=1
6pkgdesc="Wave-to-Notes transcriber (WAVE-MIDI converter)"
7arch=('i686' 'x86_64')
8url="http://waon.sourceforge.net/"
9license=('GPL2')
10depends=('fftw' 'libsamplerate' 'libao' 'gtk2')
11source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
12md5sums=('fc36842882449274ff90e3f6b55b3daa')
13
14build() {
15 cd "$srcdir/$pkgname-$pkgver"
16
17 sed -i 's:usr/local:usr:g' Makefile
18 make
19}
20
21package() {
22 cd "$srcdir/$pkgname-$pkgver"
23
24 install -Dm755 pv $pkgdir/usr/bin/waon-pv
25 install -m755 waon gwaon $pkgdir/usr/bin/
26 install -Dm644 pv.1 $pkgdir/usr/share/man/man1/waon-pv.1
27 install -m644 {waon,gwaon}.1 $pkgdir/usr/share/man/man1/
28}