diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-02-14 14:23:37 +0100 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-02-14 14:23:37 +0100 |
commit | 0e3d6dde1abc6a21490653ae17bf43c047c4b3c0 (patch) | |
tree | 0c0c40c55dfcc12f0bf807cf9e288f1d17020b3c /nix/PKGBUILD | |
parent | 9ee19ca18f89e649f8c6500079b86bd3b6912014 (diff) | |
parent | ed04b08b9b4e7c4b8c882450536895592341edcc (diff) | |
download | AUR-0e3d6dde1abc6a21490653ae17bf43c047c4b3c0.tar.gz AUR-0e3d6dde1abc6a21490653ae17bf43c047c4b3c0.tar.zst AUR-0e3d6dde1abc6a21490653ae17bf43c047c4b3c0.zip |
Add 'nix/' from commit 'ed04b08b9b4e7c4b8c882450536895592341edcc'
git-subtree-dir: nix
git-subtree-mainline: 9ee19ca18f89e649f8c6500079b86bd3b6912014
git-subtree-split: ed04b08b9b4e7c4b8c882450536895592341edcc
Diffstat (limited to 'nix/PKGBUILD')
-rw-r--r-- | nix/PKGBUILD | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/nix/PKGBUILD b/nix/PKGBUILD new file mode 100644 index 0000000..daa8e74 --- /dev/null +++ b/nix/PKGBUILD | |||
@@ -0,0 +1,42 @@ | |||
1 | # Maintainer: Alastair Pharo <asppsa at gmail dot com> | ||
2 | # Contributor: Felix Morgner <felix.morgner@gmail.com> | ||
3 | # Contributor: Vlad M. <vlad@archlinux.net> | ||
4 | # Contributor: Mario Rodas | ||
5 | # Contributor: Oozyslug <oozyslug at gmail dot com> | ||
6 | # Contributor: koral <koral at mailoo dot org> | ||
7 | # Contributor: Anders Bennehag | ||
8 | |||
9 | pkgname=nix | ||
10 | pkgver=2.2.1 | ||
11 | pkgrel=1 | ||
12 | pkgdesc="A purely functional package manager" | ||
13 | arch=('i686' 'x86_64' 'armv7h') | ||
14 | url="https://nixos.org/nix" | ||
15 | license=('LGPL') | ||
16 | depends=('gc' 'libsodium' 'boost' 'brotli' 'readline') | ||
17 | makedepends=('bzip2' 'gc' 'openssl') | ||
18 | install=nix.install | ||
19 | source=("https://nixos.org/releases/nix/nix-$pkgver/nix-$pkgver.tar.xz") | ||
20 | sha256sums=('85f8d3518060803e44e51b1a9ada1a39cea904b36a632ba1844043a0b63be515') | ||
21 | |||
22 | |||
23 | prepare() { | ||
24 | cd "$pkgname-$pkgver" | ||
25 | } | ||
26 | |||
27 | build () { | ||
28 | cd "$pkgname-$pkgver" | ||
29 | export EDITLINE_CFLAGS="-DREADLINE" | ||
30 | export EDITLINE_LIBS="/usr/lib/libreadline.so" | ||
31 | ./configure --prefix=/usr \ | ||
32 | --libexecdir="/usr/lib/$pkgname" \ | ||
33 | --sysconfdir=/etc \ | ||
34 | --enable-gc | ||
35 | make | ||
36 | } | ||
37 | |||
38 | package() { | ||
39 | cd "$pkgname-$pkgver" | ||
40 | make DESTDIR="$pkgdir" install | ||
41 | install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE" | ||
42 | } | ||