aboutsummaryrefslogtreecommitdiff
path: root/dash-static/PKGBUILD
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-02-14 14:16:10 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-02-14 14:16:10 +0100
commit383eef4b4134856f58fca6270d7cf713cf8a5400 (patch)
tree85fe7d7446ccb387daff96264c96960c3946024e /dash-static/PKGBUILD
parenta7f4e2376f48b5e35221be282d15c9b160204a67 (diff)
parentaf87ed0a69deebf7b400d8f8d88ce2342913b7fa (diff)
downloadAUR-383eef4b4134856f58fca6270d7cf713cf8a5400.tar.gz
AUR-383eef4b4134856f58fca6270d7cf713cf8a5400.tar.zst
AUR-383eef4b4134856f58fca6270d7cf713cf8a5400.zip
Add 'dash-static/' from commit 'af87ed0a69deebf7b400d8f8d88ce2342913b7fa'
git-subtree-dir: dash-static git-subtree-mainline: a7f4e2376f48b5e35221be282d15c9b160204a67 git-subtree-split: af87ed0a69deebf7b400d8f8d88ce2342913b7fa
Diffstat (limited to 'dash-static/PKGBUILD')
-rw-r--r--dash-static/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/dash-static/PKGBUILD b/dash-static/PKGBUILD
new file mode 100644
index 0000000..9a9e1e7
--- /dev/null
+++ b/dash-static/PKGBUILD
@@ -0,0 +1,25 @@
1# Maintainer : Immae <ismael.bouya@normalesup.org>
2
3pkgname=dash-static
4pkgver=0.5.10.2
5pkgrel=1
6pkgdesc="POSIX compliant shell that aims to be as small as possible. Statically compiled"
7arch=('x86_64')
8url="http://gondor.apana.org.au/~herbert/dash/"
9license=('BSD')
10source=("http://gondor.apana.org.au/~herbert/dash/files/dash-${pkgver}.tar.gz")
11sha512sums=('0ae29be77794df0ba254967649b9728611a75fbb3acd32ab6634d76399d1ce97c7d12d31da465482a7e4f3207093415c496c39525cace9b78ab3cb9444dd7640')
12
13
14build () {
15 cd "dash-$pkgver"
16 export CC="gcc -static"
17 export CFLAGS="-Os -static"
18 ./configure --with-libedit
19 make
20}
21
22package() {
23 cd "dash-$pkgver"
24 install -Dm755 src/dash $pkgdir/usr/bin/dash-static
25}