aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2015-06-14 20:10:48 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2015-06-14 20:10:48 +0200
commit89102e27361b7eef57446f8df594556acadd8ef2 (patch)
tree46a067d19ca9994e036fb9ffc9b1fcd0c36f59f5 /PKGBUILD
downloadAUR-89102e27361b7eef57446f8df594556acadd8ef2.tar.gz
AUR-89102e27361b7eef57446f8df594556acadd8ef2.tar.zst
AUR-89102e27361b7eef57446f8df594556acadd8ef2.zip
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..05415e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
1# Maintainer: Immae <ismael.bouya@normalesup.org>
2
3pkgname=patacrep-git
4pkgver=20150614
5pkgrel=1
6pkgdesc="Engine for LaTeX songbooks"
7arch=('any')
8url="http://www.patacrep.com"
9license=('GPL')
10depends=('python' 'python-ply' 'python-jinja' 'python-chardet'
11 'python-unidecode' 'texlive-fontsextra' 'lilypond')
12makedepends=('python-setuptools')
13source=("patacrep::git://github.com/patacrep/patacrep.git#branch=master")
14sha256sums=(SKIP)
15
16build() {
17 cd "$srcdir/patacrep"
18 python setup.py build
19}
20
21package(){
22 cd "$srcdir/patacrep"
23 python setup.py install --root="${pkgdir}"
24}
25