aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2015-06-14 20:15:18 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2015-06-14 20:15:18 +0200
commit77eb3fe4aed3ec1113b198680b69805566a6a4bd (patch)
treee237d372c267cf602d0e92afdc0cf4f3fe1e453c /PKGBUILD
downloadAUR-77eb3fe4aed3ec1113b198680b69805566a6a4bd.tar.gz
AUR-77eb3fe4aed3ec1113b198680b69805566a6a4bd.tar.zst
AUR-77eb3fe4aed3ec1113b198680b69805566a6a4bd.zip
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..270dc98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
1# Maintainer: Immae <ismael.bouya@normalesup.org>
2
3pkgname=patacrep
4pkgver=4.0.0
5pkgrel=1
6pkgdesc="Engine for LaTeX songbooks"
7arch=('any')
8url="http://www.patacrep.com"
9license=('GPL')
10depends=('python' 'python-ply' 'python-jinja' 'python-chardet'
11 'python-unidecode' 'texlive-fontsextra' 'lilypond')
12makedepends=('python-setuptools')
13source=("https://github.com/patacrep/${pkgname}/archive/v${pkgver}.tar.gz")
14sha256sums=('76bcec90e3326ea152d500f35719509268ea5a26996800ea5118c7e924ea726b')
15
16build() {
17 cd "$srcdir/${pkgname}-${pkgver}"
18 python setup.py build
19}
20
21package(){
22 cd "$srcdir/${pkgname}-${pkgver}"
23 python setup.py install --root="${pkgdir}"
24}
25