aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Steel <jsteel@archlinux.org>2017-06-13 14:15:42 +0100
committerJonathan Steel <jsteel@archlinux.org>2017-06-13 14:15:42 +0100
commit746bfc7e2fd0c246b880b529d02af264a1744e1d (patch)
tree18e33deefa169caaf413c53cd003031b21471c26 /PKGBUILD
parent679640f802129af0a8e9a4b6f9f31ccfd86fa2f9 (diff)
downloadAUR-746bfc7e2fd0c246b880b529d02af264a1744e1d.tar.gz
AUR-746bfc7e2fd0c246b880b529d02af264a1744e1d.tar.zst
AUR-746bfc7e2fd0c246b880b529d02af264a1744e1d.zip
gcc7 fix and run with --daemon
journalctl was very noisy without --daemon
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1511b42..4ade4bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
2 2
3pkgname=naemon 3pkgname=naemon
4pkgver=1.0.6 4pkgver=1.0.6
5pkgrel=3 5pkgrel=4
6pkgdesc="System and network monitoring application" 6pkgdesc="System and network monitoring application"
7arch=('i686' 'x86_64') 7arch=('i686' 'x86_64')
8url="http://naemon.org" 8url="http://naemon.org"
@@ -16,14 +16,22 @@ provides=('naemon-core' 'naemon-livestatus')
16conflicts=('naemon-core' 'naemon-livestatus') 16conflicts=('naemon-core' 'naemon-livestatus')
17replaces=('naemon-core' 'naemon-livestatus') 17replaces=('naemon-core' 'naemon-livestatus')
18source=(http://labs.consol.de/naemon/release/v$pkgver/src/$pkgname-$pkgver.tar.gz 18source=(http://labs.consol.de/naemon/release/v$pkgver/src/$pkgname-$pkgver.tar.gz
19 gcc7.patch
19 $pkgname.service) 20 $pkgname.service)
20md5sums=('6c9b95a737a8f232e114f4cff200ff92' 21md5sums=('6c9b95a737a8f232e114f4cff200ff92'
21 'd6a77534e612e8f65ff3360336faec77') 22 '4a6d8f9b39335dfe3348a1a20df10dfd'
23 '29f1d11c1a7f4f1515b7993c540dabe8')
22backup=('etc/logrotate.d/naemon' 24backup=('etc/logrotate.d/naemon'
23 'etc/naemon/naemon.cfg' 25 'etc/naemon/naemon.cfg'
24 'etc/naemon/resource.cfg') 26 'etc/naemon/resource.cfg')
25install=$pkgname.install 27install=$pkgname.install
26 28
29prepare() {
30 cd $pkgname-$pkgver/naemon-core
31
32 patch -Np1 -i "$srcdir"/gcc7.patch
33}
34
27build() { 35build() {
28 cd $pkgname-$pkgver 36 cd $pkgname-$pkgver
29 37
@@ -44,7 +52,7 @@ build() {
44 --with-logrotatedir="/etc/logrotate.d" \ 52 --with-logrotatedir="/etc/logrotate.d" \
45 --with-naemon-user="naemon" \ 53 --with-naemon-user="naemon" \
46 --with-naemon-group="naemon" \ 54 --with-naemon-group="naemon" \
47 --with-lockfile="/run/naemon.pid" \ 55 --with-lockfile="/run/naemon/naemon.pid" \
48 --with-thruk-user="http" \ 56 --with-thruk-user="http" \
49 --with-thruk-group="naemon" \ 57 --with-thruk-group="naemon" \
50 --with-thruk-libs="/usr/lib/naemon/perl5" \ 58 --with-thruk-libs="/usr/lib/naemon/perl5" \
@@ -76,6 +84,8 @@ package() {
76 84
77 install -Dm644 "$srcdir"/$pkgname.service \ 85 install -Dm644 "$srcdir"/$pkgname.service \
78 "$pkgdir"/usr/lib/systemd/system/$pkgname.service 86 "$pkgdir"/usr/lib/systemd/system/$pkgname.service
87 install -Dm644 naemon-core/naemon.tmpfiles.conf \
88 "$pkgdir"/usr/lib/tmpfiles.d/naemon.conf
79 89
80 # Move sample config files 90 # Move sample config files
81 mv "$pkgdir"/etc/naemon/conf.d "$pkgdir"/etc/naemon/examples 91 mv "$pkgdir"/etc/naemon/conf.d "$pkgdir"/etc/naemon/examples