aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2015-09-25 11:57:12 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2015-09-25 11:57:12 +0200
commit3b023a2912ae44b3df25c3a504ceef02340a0cf6 (patch)
tree7e9645250487d8401c488a1c75c246d2ff4b37f6 /PKGBUILD
downloadAUR-3b023a2912ae44b3df25c3a504ceef02340a0cf6.tar.gz
AUR-3b023a2912ae44b3df25c3a504ceef02340a0cf6.tar.zst
AUR-3b023a2912ae44b3df25c3a504ceef02340a0cf6.zip
Initial commit npm-cache@0.3.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..19cb00b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
1# Maintainer : Immae <ismael.bouya@normalesup.org>
2
3_npmname=npm-cache
4pkgname=nodejs-$_npmname
5pkgver=0.3.6
6pkgrel=1
7pkgdesc="A command line utility that caches dependencies installed via npm."
8arch=('any')
9url="http://gruntjs.com/"
10license=('MIT')
11depends=('nodejs' 'npm')
12source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
13noextract=($_npmname-$pkgver.tgz)
14sha256sums=('bbbabeca8f985b91443731cfdec4a9ac31b3e58369f525fe13b0c00c6f71abc8')
15options=('!emptydirs')
16
17package() {
18 local _npmdir="$pkgdir/usr/lib/node_modules/"
19 mkdir -p "$_npmdir"
20 cd "$_npmdir"
21
22 npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
23}