]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - pkgs/default.nix
13611ec8d5a637a50fda6258449ccca5de054612
[perso/Immae/Config/Nix.git] / pkgs / default.nix
1 { pkgs }:
2 with pkgs;
3 let
4 mylibs = import ../lib { inherit pkgs; };
5 in
6 rec {
7 sources = import ../nix/sources.nix;
8 myEnvironments = callPackage ../environments {};
9 boinctui = callPackage ./boinctui {};
10 cnagios = callPackage ./cnagios { inherit mylibs; };
11 commento = callPackage ./commento {};
12 flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
13 fluentd = callPackage ./fluentd {};
14 fluent-bit = callPackage ./fluent-bit {};
15 genius = callPackage ./genius {};
16 mtop = callPackage ./mtop {};
17 muttprint = callPackage ./muttprint {};
18 mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
19 nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
20 nagnu = callPackage ./nagnu { inherit mylibs; };
21 nb = callPackage ./nb {};
22 note = callPackage ./note {};
23 notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
24 notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
25 notmuch-vim = callPackage ./notmuch/notmuch-vim {};
26 pgloader = callPackage ./pgloader {};
27 predixy = callPackage ./predixy { inherit mylibs; };
28 rrsync_sudo = callPackage ./rrsync_sudo {};
29 signaldctl = callPackage ./signaldctl {};
30 telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
31 telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
32 terminal-velocity = callPackage ./terminal-velocity {};
33 tiv = callPackage ./tiv {};
34 twins = callPackage ./twins {};
35 umami = callPackage ./umami {};
36 unicodeDoc = callPackage ./unicode {};
37
38 cardano = callPackage ./crypto/cardano { inherit mylibs; };
39 cardano-cli = callPackage ./crypto/cardano-cli {};
40 iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
41 sia = callPackage ./crypto/sia {};
42
43 proftpd = callPackage ./proftpd {};
44 pure-ftpd = callPackage ./pure-ftpd {};
45
46 composerEnv = callPackage ./composer-env {};
47 webapps = callPackage ./webapps { inherit mylibs composerEnv; };
48
49 monitoring-plugins = callPackage ./monitoring-plugins {};
50 naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
51 naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
52 gearmand = callPackage ./gearmand {};
53 status_engine = {
54 module = callPackage ./status_engine/module.nix { inherit mylibs; };
55 worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
56 interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
57 };
58
59 python3PackagesPlus = callPackage ./python-packages {
60 python = python3;
61 inherit mylibs;
62 };
63 dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
64 inherit mylibs;
65 };
66 }