1 { env, ruby_2_6, bundlerEnv, defaultGemConfig, yarn2nixPackage, fetchedGithub, stdenv, writeText, pkgs }:
3 varDir = "/var/lib/mastodon_immae";
4 socketsDir = "/run/mastodon";
9 gemdir = (fetchedGithub ./mastodon.json).src;
10 groups = [ "default" "production" "test" "development" ];
11 gemConfig = defaultGemConfig // {
14 sed -i 's!s\.files.*!!' redis-rack.gemspec
19 sed -i 's!s\.files.*!!' tzinfo.gemspec
23 buildInputs = with pkgs; [ protobuf protobufc pkgconfig ];
26 buildInputs = with pkgs; [ libidn ];
29 buildInputs = with pkgs; [ pam ];
34 info = fetchedGithub ./mastodon.json;
35 packagejson = pkgs.runCommand "package.json" { buildInputs = [ pkgs.jq ]; } ''
36 cat ${info.src}/package.json | jq -r '.version = "${info.version}"' > $out
39 yarn2nixPackage.mkYarnModules rec {
40 name = "mastodon-yarn";
42 version = info.version;
43 packageJSON = packagejson;
44 yarnLock = "${info.src}/yarn.lock";
45 yarnNix = ./yarn-packages.nix;
49 npx node-gyp rebuild > build_log.txt 2>&1 || true
54 mastodon = stdenv.mkDerivation (fetchedGithub ./mastodon.json // rec {
57 cp -a ${yarnModules}/node_modules $out
59 buildInputs = [ yarnModules ];
61 config = writeText "mastodon_environment" ''
62 REDIS_HOST=${env.redis.host}
63 REDIS_PORT=${env.redis.port}
64 REDIS_DB=${env.redis.db}
65 DB_HOST=${env.postgresql.socket}
66 DB_USER=${env.postgresql.user}
67 DB_NAME=${env.postgresql.database}
68 DB_PASS=${env.postgresql.password}
69 DB_PORT=${env.postgresql.port}
71 LOCAL_DOMAIN=mastodon.immae.eu
73 ALTERNATE_DOMAINS=immae.eu
75 PAPERCLIP_SECRET=${env.paperclip_secret}
76 SECRET_KEY_BASE=${env.secret_key_base}
77 OTP_SECRET=${env.otp_secret}
79 VAPID_PRIVATE_KEY=${env.vapid.private}
80 VAPID_PUBLIC_KEY=${env.vapid.public}
82 SMTP_DELIVERY_METHOD=sendmail
83 SMTP_FROM_ADDRESS=notifications@mastodon.immae.eu
84 SENDMAIL_LOCATION="/run/wrappers/bin/sendmail"
85 PAPERCLIP_ROOT_PATH=${varDir}
87 STREAMING_CLUSTER_NUM=1
91 # LDAP authentication (optional)
93 LDAP_HOST=ldap.immae.eu
95 LDAP_METHOD=simple_tls
96 LDAP_BASE="dc=immae,dc=eu"
97 LDAP_BIND_DN="cn=mastodon,ou=services,dc=immae,dc=eu"
98 LDAP_PASSWORD="${env.ldap.password}"
100 LDAP_SEARCH_FILTER="(&(%{uid}=%{email})(memberOf=cn=users,cn=mastodon,ou=services,dc=immae,dc=eu))"
103 railsRoot = stdenv.mkDerivation {
104 name = "mastodon_immae";
105 inherit config mastodon;
106 builder = writeText "build_mastodon_immae" ''
114 chmod -R u+rwX config/
115 sed -i -e 's@^end$@ config.action_mailer.sendmail_settings = { location: ENV.fetch("SENDMAIL_LOCATION", "/usr/sbin/sendmail") }\nend@' config/environments/production.rb
116 RAILS_ENV=production ${gems}/bin/rails assets:precompile
118 ln -sf ${varDir}/tmp/cache tmp
120 buildInputs = [ gems gems.ruby pkgs.nodejs pkgs.yarn ];
124 inherit railsRoot config varDir socketsDir gems;
125 nodeSocket = "${socketsDir}/live_immae_node.sock";
126 railsSocket = "${socketsDir}/live_immae_puma.sock";