1 { stdenv, lib, src, server, client }:
2 stdenv.mkDerivation rec {
7 ln -s ${server.modules}/node_modules .
8 rm -rf dist && cp -a ${server.dist}/dist dist
9 rm -rf client/dist && cp -a ${client.dist}/dist client/
14 ln -s /tmp $out/.cache
18 description = "A free software to take back control of your videos";
21 PeerTube aspires to be a decentralized and free/libre alternative to video
22 broadcasting services.
23 PeerTube is not meant to become a huge platform that would centralize
24 videos from all around the world. Rather, it is a network of
25 inter-connected small videos hosters.
26 Anyone with a modicum of technical skills can host a PeerTube server, aka
27 an instance. Each instance hosts its users and their videos. In this way,
28 every instance is created, moderated and maintained independently by
29 various administrators.
30 You can still watch from your account videos hosted by other instances
31 though if the administrator of your instance had previously connected it
35 license = lib.licenses.agpl3Plus;
37 homepage = "https://joinpeertube.org/";
39 platforms = lib.platforms.unix;