diff options
Diffstat (limited to 'music_sampler.spec')
-rw-r--r-- | music_sampler.spec | 10 |
1 files changed, 8 insertions, 2 deletions
diff --git a/music_sampler.spec b/music_sampler.spec index 5549b76..bd69562 100644 --- a/music_sampler.spec +++ b/music_sampler.spec | |||
@@ -6,7 +6,7 @@ from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal,\ | |||
6 | 6 | ||
7 | import importlib.machinery | 7 | import importlib.machinery |
8 | sysfont = importlib.machinery\ | 8 | sysfont = importlib.machinery\ |
9 | .SourceFileLoader('sysfont', os.getcwd() + '/music_sampler/sysfont.py') \ | 9 | .SourceFileLoader('sysfont', os.getcwd()+'/music_sampler/sysfont.py') \ |
10 | .load_module() | 10 | .load_module() |
11 | 11 | ||
12 | excluded_and_hidden_modules = get_deps_minimal( | 12 | excluded_and_hidden_modules = get_deps_minimal( |
@@ -40,7 +40,13 @@ a = Analysis(['run.py'], | |||
40 | runtime_hooks=runtime_hooks(), | 40 | runtime_hooks=runtime_hooks(), |
41 | **excluded_and_hidden_modules) | 41 | **excluded_and_hidden_modules) |
42 | 42 | ||
43 | for fontname, style in [("Ubuntu", sysfont.STYLE_NORMAL), ("Ubuntu", sysfont.STYLE_BOLD), ("Symbola", sysfont.STYLE_NONE)]: | 43 | fonts = [ |
44 | ("Ubuntu", sysfont.STYLE_NORMAL), | ||
45 | ("Ubuntu", sysfont.STYLE_BOLD), | ||
46 | ("Symbola", sysfont.STYLE_NONE) | ||
47 | ] | ||
48 | |||
49 | for fontname, style in fonts: | ||
44 | font = sysfont.get_font(fontname, style=style) | 50 | font = sysfont.get_font(fontname, style=style) |
45 | a.datas.append(( | 51 | a.datas.append(( |
46 | 'fonts/{}_{}.ttf'.format(fontname, style), | 52 | 'fonts/{}_{}.ttf'.format(fontname, style), |