diff options
Diffstat (limited to 'music_sampler.spec')
-rw-r--r-- | music_sampler.spec | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/music_sampler.spec b/music_sampler.spec new file mode 100644 index 0000000..2f6f04c --- /dev/null +++ b/music_sampler.spec | |||
@@ -0,0 +1,32 @@ | |||
1 | # -*- mode: python -*- | ||
2 | |||
3 | block_cipher = None | ||
4 | |||
5 | a = Analysis(['music_sampler.py'], | ||
6 | binaries=None, | ||
7 | datas=[('config.yml', '.')], | ||
8 | hiddenimports=[ | ||
9 | 'six', | ||
10 | 'packaging', | ||
11 | 'packaging.version', | ||
12 | 'packaging.specifiers', | ||
13 | 'packaging.requirements' | ||
14 | ], | ||
15 | hookspath=[], | ||
16 | runtime_hooks=[], | ||
17 | excludes=[], | ||
18 | win_no_prefer_redirects=False, | ||
19 | win_private_assemblies=False, | ||
20 | cipher=block_cipher) | ||
21 | pyz = PYZ(a.pure, a.zipped_data, | ||
22 | cipher=block_cipher) | ||
23 | exe = EXE(pyz, | ||
24 | a.scripts, | ||
25 | a.binaries, | ||
26 | a.zipfiles, | ||
27 | a.datas, | ||
28 | name='music_sampler', | ||
29 | debug=False, | ||
30 | strip=False, | ||
31 | upx=True, | ||
32 | console=True ) | ||