aboutsummaryrefslogtreecommitdiff
path: root/music_sampler.spec
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2016-06-26 00:58:42 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2016-06-26 00:58:42 +0200
commitd8046b94a52262d1453104de2df138a952cb4548 (patch)
treeab525f83dce0f7ac63c3a9ebf86bc6d0b58c3dc3 /music_sampler.spec
parentbb69f62e140efde8e93f7b62bf8723113bf30b06 (diff)
downloadMusicSampler-d8046b94a52262d1453104de2df138a952cb4548.tar.gz
MusicSampler-d8046b94a52262d1453104de2df138a952cb4548.tar.zst
MusicSampler-d8046b94a52262d1453104de2df138a952cb4548.zip
Reduce package size
Diffstat (limited to 'music_sampler.spec')
-rw-r--r--music_sampler.spec35
1 files changed, 8 insertions, 27 deletions
diff --git a/music_sampler.spec b/music_sampler.spec
index fca4005..a56c2dd 100644
--- a/music_sampler.spec
+++ b/music_sampler.spec
@@ -1,36 +1,17 @@
1# -*- mode: python -*- 1# -*- mode: python -*-
2from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal, hookspath, runtime_hooks
2 3
3block_cipher = None 4excluded_and_hidden_modules = get_deps_minimal(video=None, camera=None, audio=None, clipboard=None, spelling=None)
5excluded_and_hidden_modules['hiddenimports'] += [ 'six', 'packaging', 'packaging.version', 'packaging.specifiers', 'packaging.requirements']
4 6
5a = Analysis(['music_sampler.py'], 7a = Analysis(['music_sampler.py'],
6 binaries=None, 8 binaries=None,
7 datas=[ 9 datas=[
8 ('config.yml', '.'),
9 ('fonts/*', 'fonts'), 10 ('fonts/*', 'fonts'),
10 ('musicsampler.kv', '.') 11 ('musicsampler.kv', '.')
11 ], 12 ],
12 hiddenimports=[ 13 hookspath=hookspath(),
13 'six', 14 runtime_hooks=runtime_hooks(),
14 'packaging', 15 **excluded_and_hidden_modules)
15 'packaging.version', 16pyz = PYZ(a.pure, a.zipped_data)
16 'packaging.specifiers', 17exe = EXE(pyz, a.scripts, a.binaries, a.zipfiles, a.datas, name='music_sampler')
17 'packaging.requirements'
18 ],
19 hookspath=[],
20 runtime_hooks=[],
21 excludes=[],
22 win_no_prefer_redirects=False,
23 win_private_assemblies=False,
24 cipher=block_cipher)
25pyz = PYZ(a.pure, a.zipped_data,
26 cipher=block_cipher)
27exe = EXE(pyz,
28 a.scripts,
29 a.binaries,
30 a.zipfiles,
31 a.datas,
32 name='music_sampler',
33 debug=False,
34 strip=False,
35 upx=True,
36 console=True )