summaryrefslogtreecommitdiff
path: root/modules/private/websites/ludivinecassal/integration.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2018-12-13 21:25:24 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-24 01:40:13 +0200
commit252dd7d899b7a0deea1537cc5d2d48b825afffb0 (patch)
treef51c3c9cd7429b0b9553a840f26bee489be045bc /modules/private/websites/ludivinecassal/integration.nix
downloadNUR-252dd7d899b7a0deea1537cc5d2d48b825afffb0.tar.gz
NUR-252dd7d899b7a0deea1537cc5d2d48b825afffb0.tar.zst
NUR-252dd7d899b7a0deea1537cc5d2d48b825afffb0.zip
Initial commit published for NURnur_root
Diffstat (limited to 'modules/private/websites/ludivinecassal/integration.nix')
-rw-r--r--modules/private/websites/ludivinecassal/integration.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/modules/private/websites/ludivinecassal/integration.nix b/modules/private/websites/ludivinecassal/integration.nix
new file mode 100644
index 00000000..ed0dc9fe
--- /dev/null
+++ b/modules/private/websites/ludivinecassal/integration.nix
@@ -0,0 +1,32 @@
1{ lib, pkgs, config, myconfig, ... }:
2let
3 ludivinecassal = pkgs.callPackage ./builder.nix {
4 inherit (pkgs.webapps) ludivinecassal;
5 config = myconfig.env.websites.ludivinecassal.integration;
6 apacheUser = config.services.httpd.Inte.user;
7 apacheGroup = config.services.httpd.Inte.group;
8 };
9
10 cfg = config.myServices.websites.ludivinecassal.integration;
11in {
12 options.myServices.websites.ludivinecassal.integration.enable = lib.mkEnableOption "enable Ludivine's website in integration";
13
14 config = lib.mkIf cfg.enable {
15 secrets.keys = ludivinecassal.keys;
16
17 systemd.services.phpfpm-ludivinecassal_dev.after = lib.mkAfter ludivinecassal.phpFpm.serviceDeps;
18 systemd.services.phpfpm-ludivinecassal_dev.wants = ludivinecassal.phpFpm.serviceDeps;
19 systemd.services.phpfpm-ludivinecassal_dev.preStart = lib.mkAfter ludivinecassal.phpFpm.preStart;
20 services.phpfpm.poolConfigs.ludivinecassal_dev = ludivinecassal.phpFpm.pool;
21 system.activationScripts.ludivinecassal_dev = ludivinecassal.activationScript;
22 myServices.websites.webappDirs."${ludivinecassal.apache.webappName}" = ludivinecassal.app.webRoot;
23 services.websites.integration.modules = ludivinecassal.apache.modules;
24 services.websites.integration.vhostConfs.ludivine = {
25 certName = "eldiron";
26 addToCerts = true;
27 hosts = [ "ludivine.immae.eu" ];
28 root = ludivinecassal.apache.root;
29 extraConfig = [ ludivinecassal.apache.vhostConf ];
30 };
31 };
32}