{ lib, writeText, fetchedGitPrivate, stdenv, php, git, cacert }:
let
connexionswing = { config }: rec {
environment = config.environment;
varDir = "/var/lib/connexionswing_${environment}";
envName= lib.strings.toUpper environment;
configRoot =
writeText "parameters.yml" ''
# This file is auto-generated during the composer install
parameters:
database_host: db-1.immae.eu
database_port: null
database_name: ${config.mysql.name}
database_user: ${config.mysql.user}
database_password: ${config.mysql.password}
mailer_transport: smtp
mailer_host: mail.immae.eu
mailer_user: null
mailer_password: null
subscription_email: ${config.email}
allow_robots: true
secret: ${config.secret}
'';
phpFpm = rec {
socket = "/var/run/phpfpm/connexionswing-${environment}.sock";
pool = ''
listen = ${socket}
user = ${apache.user}
group = ${apache.group}
listen.owner = ${apache.user}
listen.group = ${apache.group}
php_admin_value[upload_max_filesize] = 20M
php_admin_value[post_max_size] = 20M
;php_admin_flag[log_errors] = on
php_admin_value[open_basedir] = "${configRoot}:${webappDir}:${varDir}:/tmp"
php_admin_value[session.save_path] = "${varDir}/phpSessions"
${if environment == "dev" then ''
pm = ondemand
pm.max_children = 5
pm.process_idle_timeout = 60
env[SYMFONY_DEBUG_MODE] = "yes"
'' else ''
pm = dynamic
pm.max_children = 20
pm.start_servers = 2
pm.min_spare_servers = 1
pm.max_spare_servers = 3
''}'';
};
apache = {
user = "wwwrun";
group = "wwwrun";
modules = [ "proxy_fcgi" ];
vhostConf = ''
SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"
Options FollowSymLinks
AllowOverride None
Require all granted
Options FollowSymLinks
AllowOverride None
Require all granted
${if environment == "dev" then ''
Use LDAPConnect
Require ldap-group cn=connexionswing.immae.eu,cn=httpd,ou=services,dc=immae,dc=eu
ErrorDocument 401 ""
Options Indexes FollowSymLinks MultiViews Includes
AllowOverride None
Require all granted
DirectoryIndex app_dev.php
Options -MultiViews
RewriteEngine On
RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
RewriteRule ^(.*) - [E=BASE:%1]
# Maintenance script
RewriteCond %{DOCUMENT_ROOT}/maintenance.php -f
RewriteCond %{SCRIPT_FILENAME} !maintenance.php
RewriteRule ^.*$ %{ENV:BASE}/maintenance.php [R=503,L]
ErrorDocument 503 /maintenance.php
# Sets the HTTP_AUTHORIZATION header removed by Apache
RewriteCond %{HTTP:Authorization} .
RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteCond %{ENV:REDIRECT_STATUS} ^$
RewriteRule ^app_dev\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]
# If the requested filename exists, simply serve it.
# We only want to let Apache serve files and not directories.
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule ^ - [L]
# Rewrite all other queries to the front controller.
RewriteRule ^ %{ENV:BASE}/app_dev.php [L]
'' else ''
Use Stats connexionswing.com
Options Indexes FollowSymLinks MultiViews Includes
AllowOverride All
Require all granted
''}
'';
};
activationScript = {
deps = [ "wrappers" ];
text = ''
install -m 0755 -o ${apache.user} -g ${apache.group} -d ${varDir} \
${varDir}/medias \
${varDir}/uploads \
${varDir}/var
install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions
if [ ! -f "${varDir}/currentWebappDir" -o \
"${webappDir}" != "$(cat ${varDir}/currentWebappDir 2>/dev/null)" ]; then
pushd ${webappDir} > /dev/null
$wrapperDir/sudo -u wwwrun ./bin/console --env=${environment} cache:clear --no-warmup
popd > /dev/null
echo -n "${webappDir}" > ${varDir}/currentWebappDir
fi
'';
};
webappDir = stdenv.mkDerivation (fetchedGitPrivate ./connexionswing.json // rec {
buildPhase = ''
export GIT_SSL_CAINFO=${cacert}/etc/ssl/certs/ca-bundle.crt
export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
ln -sf ../../../../../${varDir}/{medias,uploads} web/images/
ln -sf ${configRoot} app/config/parameters.yml
sed -i -e "/Incenteev..ParameterHandler..ScriptHandler::buildParameters/d" composer.json
${if environment == "dev" then "php bin/composer install" else ''
SYMFONY_ENV=prod php bin/composer install --no-dev
./bin/console assetic:dump --env=prod --no-debug
''}
rm -rf var
ln -sf ../../../../../${varDir}/var var
'';
installPhase = ''
cp -a . $out
'';
buildInputs = [
php git cacert
];
});
webRoot = "${webappDir}/web";
};
in
connexionswing