{ lib, pkgs, config, myconfig, ... }:
let
cfg = config.services.myWebsites.Temp;
varDir = "/var/lib/ftp/temp.immae.eu";
env = myconfig.env.websites.temp;
in {
options.services.myWebsites.Temp = {
production = {
enable = lib.mkEnableOption "enable Temp' website";
};
};
config = lib.mkIf cfg.production.enable {
services.websites.production.modules = [ "headers" ];
services.websites.production.vhostConfs.temp = {
certName = "eldiron";
addToCerts = true;
hosts = [ "temp.immae.eu" ];
root = varDir;
extraConfig = [
''
Use Apaxy "${varDir}" "title .duplicity-ignore"
Header set Content-Disposition attachment
Options -Indexes
AllowOverride None
Require all granted
Options Indexes
''
];
};
};
}