aboutsummaryrefslogtreecommitdiff
path: root/virtual/modules/websites/chloe.nix
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/modules/websites/chloe.nix')
-rw-r--r--virtual/modules/websites/chloe.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/virtual/modules/websites/chloe.nix b/virtual/modules/websites/chloe.nix
index d54c42d..67e8e1f 100644
--- a/virtual/modules/websites/chloe.nix
+++ b/virtual/modules/websites/chloe.nix
@@ -26,13 +26,25 @@ in {
26 26
27 services.phpfpm.poolConfigs.chloe_prod = chloe_prod.phpFpm.pool; 27 services.phpfpm.poolConfigs.chloe_prod = chloe_prod.phpFpm.pool;
28 system.activationScripts.chloe_prod = chloe_prod.activationScript; 28 system.activationScripts.chloe_prod = chloe_prod.activationScript;
29 services.myWebsites.apacheConfig.chloe_prod.modules = chloe_prod.apache.modules; 29 services.myWebsites.production.modules = chloe_prod.apache.modules;
30 services.myWebsites.production.vhostConfs.chloe = {
31 certName = "chloe";
32 hosts = ["osteopathe-cc.fr" "www.osteopathe-cc.fr" ];
33 root = chloe_prod.webRoot;
34 extraConfig = [ chloe_prod.apache.vhostConf ];
35 };
30 }) 36 })
31 (lib.mkIf cfg.integration.enable { 37 (lib.mkIf cfg.integration.enable {
32 security.acme.certs."eldiron".extraDomains."chloe.immae.eu" = null; 38 security.acme.certs."eldiron".extraDomains."chloe.immae.eu" = null;
33 services.phpfpm.poolConfigs.chloe_dev = chloe_dev.phpFpm.pool; 39 services.phpfpm.poolConfigs.chloe_dev = chloe_dev.phpFpm.pool;
34 system.activationScripts.chloe_dev = chloe_dev.activationScript; 40 system.activationScripts.chloe_dev = chloe_dev.activationScript;
35 services.myWebsites.apacheConfig.chloe_dev.modules = chloe_dev.apache.modules; 41 services.myWebsites.integration.modules = chloe_dev.apache.modules;
42 services.myWebsites.integration.vhostConfs.chloe = {
43 certName = "eldiron";
44 hosts = ["chloe.immae.eu" ];
45 root = chloe_dev.webRoot;
46 extraConfig = [ chloe_dev.apache.vhostConf ];
47 };
36 }) 48 })
37 ]; 49 ];
38} 50}