diff options
Diffstat (limited to 'pkgs/telegramircd')
-rw-r--r-- | pkgs/telegramircd/default.nix | 16 | ||||
-rw-r--r-- | pkgs/telegramircd/telegramircd.json | 15 |
2 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/telegramircd/default.nix b/pkgs/telegramircd/default.nix new file mode 100644 index 0000000..8c8bddc --- /dev/null +++ b/pkgs/telegramircd/default.nix | |||
@@ -0,0 +1,16 @@ | |||
1 | { openssl, telethon, python3Packages, fetchedGithub }: | ||
2 | with python3Packages; | ||
3 | buildPythonApplication rec { | ||
4 | format = "other"; | ||
5 | pname = "telegramircd"; | ||
6 | version = "master"; | ||
7 | propagatedBuildInputs = [ telethon aiohttp ConfigArgParse openssl ]; | ||
8 | src = (fetchedGithub ./telegramircd.json).src; | ||
9 | LD_LIBRARY_PATH = "${openssl.out}/lib"; | ||
10 | installPhase = '' | ||
11 | install -D $src/telegramircd.py $out/bin/telegramircd | ||
12 | wrapProgram "$out/bin/telegramircd" \ | ||
13 | --prefix LD_LIBRARY_PATH : "${openssl.out}/lib" | ||
14 | install -Dm644 "$src/config" -t "$out/etc/telegramircd/" | ||
15 | ''; | ||
16 | } | ||
diff --git a/pkgs/telegramircd/telegramircd.json b/pkgs/telegramircd/telegramircd.json new file mode 100644 index 0000000..3d219f8 --- /dev/null +++ b/pkgs/telegramircd/telegramircd.json | |||
@@ -0,0 +1,15 @@ | |||
1 | { | ||
2 | "tag": "40a0c7c-master", | ||
3 | "meta": { | ||
4 | "name": "telegramircd", | ||
5 | "url": "https://github.com/MaskRay/telegramircd", | ||
6 | "branch": "master" | ||
7 | }, | ||
8 | "github": { | ||
9 | "owner": "MaskRay", | ||
10 | "repo": "telegramircd", | ||
11 | "rev": "40a0c7cf60492bde3f44d43f06f62e3792480139", | ||
12 | "sha256": "123fjhgxq2fzn0ar8274jv7jjbxnlpidrj5333kbch7rpcipks0y", | ||
13 | "fetchSubmodules": true | ||
14 | } | ||
15 | } | ||