aboutsummaryrefslogtreecommitdiff
path: root/pkgs/telegramircd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/telegramircd/default.nix')
-rw-r--r--pkgs/telegramircd/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/telegramircd/default.nix b/pkgs/telegramircd/default.nix
index 8c8bddc..2f1d7ca 100644
--- a/pkgs/telegramircd/default.nix
+++ b/pkgs/telegramircd/default.nix
@@ -1,11 +1,11 @@
1{ openssl, telethon, python3Packages, fetchedGithub }: 1{ openssl, telethon, python3Packages, mylibs }:
2with python3Packages; 2with python3Packages;
3buildPythonApplication rec { 3buildPythonApplication rec {
4 format = "other"; 4 format = "other";
5 pname = "telegramircd"; 5 pname = "telegramircd";
6 version = "master"; 6 version = "master";
7 propagatedBuildInputs = [ telethon aiohttp ConfigArgParse openssl ]; 7 propagatedBuildInputs = [ telethon aiohttp ConfigArgParse openssl ];
8 src = (fetchedGithub ./telegramircd.json).src; 8 src = (mylibs.fetchedGithub ./telegramircd.json).src;
9 LD_LIBRARY_PATH = "${openssl.out}/lib"; 9 LD_LIBRARY_PATH = "${openssl.out}/lib";
10 installPhase = '' 10 installPhase = ''
11 install -D $src/telegramircd.py $out/bin/telegramircd 11 install -D $src/telegramircd.py $out/bin/telegramircd