aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/databases/postgresql.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/databases/postgresql.nix')
-rw-r--r--nixops/modules/databases/postgresql.nix12
1 files changed, 0 insertions, 12 deletions
diff --git a/nixops/modules/databases/postgresql.nix b/nixops/modules/databases/postgresql.nix
index 62e9e34..0afce70 100644
--- a/nixops/modules/databases/postgresql.nix
+++ b/nixops/modules/databases/postgresql.nix
@@ -14,18 +14,6 @@ in {
14 }; 14 };
15 15
16 config = lib.mkIf cfg.enable { 16 config = lib.mkIf cfg.enable {
17 nixpkgs.overlays = [ (self: super: rec {
18 postgresql = postgresql_11;
19 postgresql_11 = super.postgresql_11.overrideAttrs(old: rec {
20 passthru = old.passthru // { psqlSchema = "11.0"; };
21 configureFlags = old.configureFlags ++ [ "--with-pam" ];
22 buildInputs = (old.buildInputs or []) ++ [ self.pam ];
23 patches = old.patches ++ [
24 ./postgresql_run_socket_path.patch
25 ];
26 });
27 }) ];
28
29 networking.firewall.allowedTCPPorts = [ 5432 ]; 17 networking.firewall.allowedTCPPorts = [ 5432 ];
30 18
31 security.acme.certs."postgresql" = config.services.myCertificates.certConfig // { 19 security.acme.certs."postgresql" = config.services.myCertificates.certConfig // {