aboutsummaryrefslogtreecommitdiff
path: root/modules/websites/php-application.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/websites/php-application.nix')
-rw-r--r--modules/websites/php-application.nix19
1 files changed, 0 insertions, 19 deletions
diff --git a/modules/websites/php-application.nix b/modules/websites/php-application.nix
index 23e2b23..3a43a45 100644
--- a/modules/websites/php-application.nix
+++ b/modules/websites/php-application.nix
@@ -110,13 +110,6 @@ in
110 Path to application root 110 Path to application root
111 ''; 111 '';
112 }; 112 };
113 webappName = mkOption {
114 type = nullOr str;
115 default = null;
116 description = ''
117 Alias name for the app, to be used in services.websites.webappDirs
118 '';
119 };
120 webRoot = mkOption { 113 webRoot = mkOption {
121 type = nullOr path; 114 type = nullOr path;
122 description = '' 115 description = ''
@@ -152,14 +145,6 @@ in
152 Full paths to listen for php 145 Full paths to listen for php
153 ''; 146 '';
154 }; 147 };
155 services.phpApplication.webappDirs = mkOption {
156 type = attrsOf path;
157 default = attrsets.filterAttrs (n: v: builtins.hasAttr n cfg.apps) config.services.websites.webappDirsPaths;
158 readOnly = true;
159 description = ''
160 Stable name webapp dirs for httpd
161 '';
162 };
163 }; 148 };
164 149
165 config = { 150 config = {
@@ -186,10 +171,6 @@ in
186 } 171 }
187 ) cfg.apps; 172 ) cfg.apps;
188 173
189 services.websites.webappDirs = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair
190 (if icfg.webappName == null then name else icfg.webappName) icfg.webRoot
191 ) (attrsets.filterAttrs (n: v: !isNull v.webRoot) cfg.apps);
192
193 services.filesWatcher = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair 174 services.filesWatcher = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair
194 "phpfpm-${name}" { 175 "phpfpm-${name}" {
195 restart = true; 176 restart = true;