aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/emilia/moodle.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/emilia/moodle.nix')
-rw-r--r--modules/private/websites/emilia/moodle.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/modules/private/websites/emilia/moodle.nix b/modules/private/websites/emilia/moodle.nix
index d49faf5..f943502 100644
--- a/modules/private/websites/emilia/moodle.nix
+++ b/modules/private/websites/emilia/moodle.nix
@@ -4,8 +4,6 @@ let
4 env = config.myEnv.websites.emilia; 4 env = config.myEnv.websites.emilia;
5 varDir = "/var/lib/emilia_moodle"; 5 varDir = "/var/lib/emilia_moodle";
6 siteDir = ./moodle; 6 siteDir = ./moodle;
7 webappName = "emilia_moodle";
8 webappdir = config.services.websites.webappDirsPaths.emilia_moodle;
9 # php_admin_value[upload_max_filesize] = 50000000 7 # php_admin_value[upload_max_filesize] = 50000000
10 # php_admin_value[post_max_size] = 50000000 8 # php_admin_value[post_max_size] = 50000000
11 configFile = '' 9 configFile = ''
@@ -49,15 +47,14 @@ in {
49 system.activationScripts.emilia_moodle = '' 47 system.activationScripts.emilia_moodle = ''
50 install -m 0755 -o ${apacheUser} -g ${apacheGroup} -d ${varDir} 48 install -m 0755 -o ${apacheUser} -g ${apacheGroup} -d ${varDir}
51 ''; 49 '';
52 services.websites.webappDirs.emilia_moodle = siteDir;
53 services.websites.env.production.vhostConfs.emilia_moodle = { 50 services.websites.env.production.vhostConfs.emilia_moodle = {
54 certName = "emilia"; 51 certName = "emilia";
55 certMainHost = "saison-photo.org"; 52 certMainHost = "saison-photo.org";
56 hosts = [ "saison-photo.org" "www.saison-photo.org" ]; 53 hosts = [ "saison-photo.org" "www.saison-photo.org" ];
57 root = webappdir; 54 root = siteDir;
58 extraConfig = [ 55 extraConfig = [
59 '' 56 ''
60 <Directory ${webappdir}> 57 <Directory ${siteDir}>
61 DirectoryIndex pause.html 58 DirectoryIndex pause.html
62 Options Indexes FollowSymLinks MultiViews Includes 59 Options Indexes FollowSymLinks MultiViews Includes
63 Require all granted 60 Require all granted