aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/default.nix')
-rw-r--r--modules/private/websites/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/private/websites/default.nix b/modules/private/websites/default.nix
index aba30e3..a3dcbb9 100644
--- a/modules/private/websites/default.nix
+++ b/modules/private/websites/default.nix
@@ -3,6 +3,19 @@ let
3 www_root = "/run/current-system/webapps/_www"; 3 www_root = "/run/current-system/webapps/_www";
4 theme_root = "/run/current-system/webapps/_theme"; 4 theme_root = "/run/current-system/webapps/_theme";
5 apacheConfig = { 5 apacheConfig = {
6 cache = {
7 # This setting permits to ignore time-based cache for files in the
8 # nix store:
9 # If a client requires an If-Modified-Since from timestamp 1, then
10 # this header is removed, and if the response contains a
11 # too old Last-Modified tag, then it is removed too
12 extraConfig = ''
13 <If "%{HTTP:If-Modified-Since} =~ /01 Jan 1970 00:00:01/" >
14 RequestHeader unset If-Modified-Since
15 </If>
16 Header unset Last-Modified "expr=%{LAST_MODIFIED} < 19991231235959"
17 '';
18 };
6 gzip = { 19 gzip = {
7 modules = [ "deflate" "filter" ]; 20 modules = [ "deflate" "filter" ];
8 extraConfig = '' 21 extraConfig = ''