aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index c4c32c8..3b51f37 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -114,6 +114,14 @@ let
114 description = "Host FQDN"; 114 description = "Host FQDN";
115 type = str; 115 type = str;
116 }; 116 };
117 users = mkOption {
118 type = unspecified;
119 default = pkgs: [];
120 description = ''
121 Sublist of users from realUsers. Function that takes pkgs as
122 argument and gives an array as a result
123 '';
124 };
117 emails = mkOption { 125 emails = mkOption {
118 default = []; 126 default = [];
119 description = "List of e-mails that the server can be a sender of"; 127 description = "List of e-mails that the server can be a sender of";
@@ -287,6 +295,14 @@ in
287 }; 295 };
288 }; 296 };
289 }; 297 };
298 realUsers = mkOption {
299 description = ''
300 Attrset of function taking pkgs as argument.
301 Real users settings, should provide a subattr of users.users.<name>
302 with at least: name, (hashed)Password, shell
303 '';
304 type = attrsOf unspecified;
305 };
290 users = mkOption { 306 users = mkOption {
291 description = "System and regular users uid/gid"; 307 description = "System and regular users uid/gid";
292 type = attrsOf (submodule { 308 type = attrsOf (submodule {