aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 674a72f..4bae440 100644
--- a/default.nix
+++ b/default.nix
@@ -496,6 +496,43 @@ let
496 ''; 496 '';
497 }; 497 };
498 498
499 mypkgs.telegramircd = with python3Packages; let
500 telethon = buildPythonPackage rec {
501 pname = "Telethon-sync";
502 version = "1.1.1";
503
504 src = fetchPypi {
505 inherit pname version;
506 sha256 =
507 "01z8fzqn0qs5pxhvzq891r3mwffq1ga3f8xvm7qdn6kvmxjni9fy";
508 };
509
510 propagatedBuildInputs = with self; [
511 rsa pyaes async_generator
512 ];
513 doCheck = false;
514
515 meta = with lib; {
516 homepage = https://github.com/LonamiWebs/Telethon;
517 description = "Full-featured Telegram client library for Python 3";
518 license = licenses.mit;
519 };
520 };
521 in
522 buildPythonApplication rec {
523 format = "other";
524 pname = "telegramircd";
525 version = "master";
526 propagatedBuildInputs = [ telethon aiohttp ConfigArgParse openssl ];
527 src = (fetchedGithub ./fetched/telegramircd.json).src;
528 LD_LIBRARY_PATH = "${openssl.out}/lib";
529 installPhase = ''
530 install -D $src/telegramircd.py $out/bin/telegramircd
531 wrapProgram "$out/bin/telegramircd" \
532 --prefix LD_LIBRARY_PATH : "${openssl.out}/lib"
533 install -Dm644 "$src/config" -t "$out/etc/telegramircd/"
534 '';
535 };
499# https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh 536# https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
500# https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks 537# https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
501in 538in