diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-05-06 14:06:31 +0200 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2019-05-06 14:06:31 +0200 |
commit | 43dac87fef530d52961cb7df5fdb01aa651d802c (patch) | |
tree | 341a5111afa74eae4070e109dd0a2b30e1ca6162 /pkgs/webapps/mantisbt_2/plugins/source-integration | |
parent | 7f9bc878c96b4e40b72c907cded326fc6bdee38a (diff) | |
download | Nix-43dac87fef530d52961cb7df5fdb01aa651d802c.tar.gz Nix-43dac87fef530d52961cb7df5fdb01aa651d802c.tar.zst Nix-43dac87fef530d52961cb7df5fdb01aa651d802c.zip |
Migrate mantisbt to pkgs
Diffstat (limited to 'pkgs/webapps/mantisbt_2/plugins/source-integration')
-rw-r--r-- | pkgs/webapps/mantisbt_2/plugins/source-integration/Source.API.php.diff | 12 | ||||
-rw-r--r-- | pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix | 21 |
2 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/webapps/mantisbt_2/plugins/source-integration/Source.API.php.diff b/pkgs/webapps/mantisbt_2/plugins/source-integration/Source.API.php.diff new file mode 100644 index 0000000..c355144 --- /dev/null +++ b/pkgs/webapps/mantisbt_2/plugins/source-integration/Source.API.php.diff | |||
@@ -0,0 +1,12 @@ | |||
1 | --- b/Source/Source.API.php 2017-09-18 00:50:32.000000000 +0200 | ||
2 | +++ a/Source/Source.API.php 2018-03-04 19:00:25.578889039 +0100 | ||
3 | @@ -452,6 +452,9 @@ | ||
4 | # Allow other plugins to post-process commit data | ||
5 | event_signal( 'EVENT_SOURCE_COMMITS', array( $p_changesets ) ); | ||
6 | event_signal( 'EVENT_SOURCE_FIXED', array( $t_fixed_bugs ) ); | ||
7 | + foreach( $t_fixed_bugs as $t_bug_id => $t_changeset ) { | ||
8 | + event_signal( 'EVENT_BUG_ACTION', array('RESOLVE', $t_bug_id) ); | ||
9 | + } | ||
10 | } | ||
11 | |||
12 | /** | ||
diff --git a/pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix b/pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix new file mode 100644 index 0000000..dc6c7de --- /dev/null +++ b/pkgs/webapps/mantisbt_2/plugins/source-integration/default.nix | |||
@@ -0,0 +1,21 @@ | |||
1 | { stdenv, fetchFromGitHub }: | ||
2 | stdenv.mkDerivation rec { | ||
3 | version = "v2.2.0"; | ||
4 | name = "mantisbt-plugin-source-integration-${version}"; | ||
5 | src = fetchFromGitHub { | ||
6 | owner = "mantisbt-plugins"; | ||
7 | repo = "source-integration"; | ||
8 | rev = "44fc9e2e770aff4f40f56833f26a86ce0e2deb76"; | ||
9 | sha256 = "0gcm6kqqijnv303sk59zn27adwx5vkr545mwzyaq2nrpxnkwdy5b"; | ||
10 | }; | ||
11 | patches = [ | ||
12 | ./Source.API.php.diff | ||
13 | ]; | ||
14 | installPhase = '' | ||
15 | mkdir $out | ||
16 | cp -a Source* $out/ | ||
17 | ''; | ||
18 | passthru = { | ||
19 | selector = "Source*"; | ||
20 | }; | ||
21 | } | ||