aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/tools/ether/etherpad_lite.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-25 09:05:46 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-04-25 09:05:46 +0200
commit32c84ff89c2b8931f58cea63961a178a9b1d0efe (patch)
tree7a90c28e1db3d8c704b2371737f2f2fae471db67 /nixops/modules/websites/tools/ether/etherpad_lite.nix
parent742697c95318d3625298437995e948ee00a00ba5 (diff)
downloadNix-32c84ff89c2b8931f58cea63961a178a9b1d0efe.tar.gz
Nix-32c84ff89c2b8931f58cea63961a178a9b1d0efe.tar.zst
Nix-32c84ff89c2b8931f58cea63961a178a9b1d0efe.zip
Move etherpad mastodon mediagoblin task and peertube to new secrets
Diffstat (limited to 'nixops/modules/websites/tools/ether/etherpad_lite.nix')
-rw-r--r--nixops/modules/websites/tools/ether/etherpad_lite.nix26
1 files changed, 13 insertions, 13 deletions
diff --git a/nixops/modules/websites/tools/ether/etherpad_lite.nix b/nixops/modules/websites/tools/ether/etherpad_lite.nix
index 689156e..14ad565 100644
--- a/nixops/modules/websites/tools/ether/etherpad_lite.nix
+++ b/nixops/modules/websites/tools/ether/etherpad_lite.nix
@@ -30,19 +30,19 @@ let
30 "ep_subscript_and_superscript" 30 "ep_subscript_and_superscript"
31 "ep_timesliderdiff" 31 "ep_timesliderdiff"
32 ]; 32 ];
33 keys = { 33 keys = [
34 tools-etherpad-apikey = { 34 {
35 destDir = "/run/keys/webapps"; 35 dest = "webapps/tools-etherpad-apikey";
36 permissions = "0400"; 36 permissions = "0400";
37 text = env.api_key; 37 text = env.api_key;
38 }; 38 }
39 tools-etherpad-sessionkey = { 39 {
40 destDir = "/run/keys/webapps"; 40 dest = "webapps/tools-etherpad-sessionkey";
41 permissions = "0400"; 41 permissions = "0400";
42 text = env.session_key; 42 text = env.session_key;
43 }; 43 }
44 tools-etherpad = { 44 {
45 destDir = "/run/keys/webapps"; 45 dest = "webapps/tools-etherpad";
46 permissions = "0400"; 46 permissions = "0400";
47 text = 47 text =
48 # Make sure we’re not rebuilding whole libreoffice just because of a 48 # Make sure we’re not rebuilding whole libreoffice just because of a
@@ -144,8 +144,8 @@ let
144 "logconfig" : { "appenders": [ { "type": "console" } ] } 144 "logconfig" : { "appenders": [ { "type": "console" } ] }
145 } 145 }
146 ''; 146 '';
147 }; 147 }
148 }; 148 ];
149 webappDir = stdenv.mkDerivation (fetchedGithub ./etherpad-lite.json // rec { 149 webappDir = stdenv.mkDerivation (fetchedGithub ./etherpad-lite.json // rec {
150 __noChroot = true; 150 __noChroot = true;
151 patches = [ ./libreoffice_patch.diff ]; 151 patches = [ ./libreoffice_patch.diff ];
@@ -182,8 +182,8 @@ let
182 install -t $out/src/ -vDm 644 src/.ep_initialized 182 install -t $out/src/ -vDm 644 src/.ep_initialized
183 cp -a node_modules $out/ 183 cp -a node_modules $out/
184 cp -a src/* $out/src/ 184 cp -a src/* $out/src/
185 ln -sf /run/keys/webapps/tools-etherpad-sessionkey $out/SESSIONKEY.txt 185 ln -sf /var/secrets/webapps/tools-etherpad-sessionkey $out/SESSIONKEY.txt
186 ln -sf /run/keys/webapps/tools-etherpad-apikey $out/APIKEY.txt 186 ln -sf /var/secrets/webapps/tools-etherpad-apikey $out/APIKEY.txt
187 cp ${jquery} $out/src/static/js/jquery.js 187 cp ${jquery} $out/src/static/js/jquery.js
188 188
189 mkdir $out/doc 189 mkdir $out/doc