aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/chloe/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-11 16:55:50 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-11 17:06:20 +0200
commit7667c367033b15582cf383da62446f78e66a59ef (patch)
tree5349427aa43070dd603802f68963b30c1c544232 /nixops/modules/websites/chloe/default.nix
parentc890321db12036be69ebbece202984874b1e5a57 (diff)
downloadNix-7667c367033b15582cf383da62446f78e66a59ef.tar.gz
Nix-7667c367033b15582cf383da62446f78e66a59ef.tar.zst
Nix-7667c367033b15582cf383da62446f78e66a59ef.zip
Move spip and chloe website to pkgs
Diffstat (limited to 'nixops/modules/websites/chloe/default.nix')
-rw-r--r--nixops/modules/websites/chloe/default.nix21
1 files changed, 11 insertions, 10 deletions
diff --git a/nixops/modules/websites/chloe/default.nix b/nixops/modules/websites/chloe/default.nix
index a542d70..874b81b 100644
--- a/nixops/modules/websites/chloe/default.nix
+++ b/nixops/modules/websites/chloe/default.nix
@@ -1,14 +1,15 @@
1{ lib, pkgs, config, myconfig, mylibs, ... }: 1{ lib, pkgs, config, myconfig, mylibs, ... }:
2let 2let
3 chloe = pkgs.callPackage ./chloe.nix { inherit (mylibs) fetchedGitPrivate; }; 3 chloe_dev = pkgs.callPackage ./chloe.nix {
4 chloe_dev = chloe { 4 inherit (pkgs.private.webapps) chloe;
5 config = myconfig.env.websites.chloe.integration; 5 config = myconfig.env.websites.chloe.integration;
6 }; 6 };
7 chloe_prod = chloe { 7 chloe_prod = pkgs.callPackage ./chloe.nix {
8 config = myconfig.env.websites.chloe.production; 8 inherit (pkgs.private.webapps) chloe;
9 }; 9 config = myconfig.env.websites.chloe.production;
10 };
10 11
11 cfg = config.services.myWebsites.Chloe; 12 cfg = config.services.myWebsites.Chloe;
12in { 13in {
13 options.services.myWebsites.Chloe = { 14 options.services.myWebsites.Chloe = {
14 production = { 15 production = {
@@ -39,7 +40,7 @@ in {
39 system.activationScripts.chloe_prod = chloe_prod.activationScript; 40 system.activationScripts.chloe_prod = chloe_prod.activationScript;
40 system.extraSystemBuilderCmds = '' 41 system.extraSystemBuilderCmds = ''
41 mkdir -p $out/webapps 42 mkdir -p $out/webapps
42 ln -s ${chloe_prod.webRoot} $out/webapps/${chloe_prod.apache.webappName} 43 ln -s ${chloe_prod.app.webRoot} $out/webapps/${chloe_prod.apache.webappName}
43 ''; 44 '';
44 services.myWebsites.production.modules = chloe_prod.apache.modules; 45 services.myWebsites.production.modules = chloe_prod.apache.modules;
45 services.myWebsites.production.vhostConfs.chloe = { 46 services.myWebsites.production.vhostConfs.chloe = {
@@ -60,7 +61,7 @@ in {
60 system.activationScripts.chloe_dev = chloe_dev.activationScript; 61 system.activationScripts.chloe_dev = chloe_dev.activationScript;
61 system.extraSystemBuilderCmds = '' 62 system.extraSystemBuilderCmds = ''
62 mkdir -p $out/webapps 63 mkdir -p $out/webapps
63 ln -s ${chloe_dev.webRoot} $out/webapps/${chloe_dev.apache.webappName} 64 ln -s ${chloe_dev.app.webRoot} $out/webapps/${chloe_dev.apache.webappName}
64 ''; 65 '';
65 services.myWebsites.integration.modules = chloe_dev.apache.modules; 66 services.myWebsites.integration.modules = chloe_dev.apache.modules;
66 services.myWebsites.integration.vhostConfs.chloe = { 67 services.myWebsites.integration.vhostConfs.chloe = {