aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/tools/git/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /modules/private/websites/tools/git/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'modules/private/websites/tools/git/default.nix')
-rw-r--r--modules/private/websites/tools/git/default.nix49
1 files changed, 0 insertions, 49 deletions
diff --git a/modules/private/websites/tools/git/default.nix b/modules/private/websites/tools/git/default.nix
deleted file mode 100644
index 8f611ee..0000000
--- a/modules/private/websites/tools/git/default.nix
+++ /dev/null
@@ -1,49 +0,0 @@
1{ lib, pkgs, config, ... }:
2let
3 mantisbt = pkgs.callPackage ./mantisbt.nix {
4 inherit (pkgs.webapps) mantisbt_2 mantisbt_2-plugins;
5 env = config.myEnv.tools.mantisbt;
6 inherit config;
7 };
8 gitweb = pkgs.callPackage ./gitweb.nix {
9 gitoliteDir = config.myServices.gitolite.gitoliteDir;
10 };
11
12 cfg = config.myServices.websites.tools.git;
13in {
14 options.myServices.websites.tools.git = {
15 enable = lib.mkEnableOption "enable git's website";
16 };
17
18 config = lib.mkIf cfg.enable {
19 secrets.keys = mantisbt.keys;
20 services.websites.env.tools.modules =
21 gitweb.apache.modules ++
22 mantisbt.apache.modules;
23
24 system.activationScripts.mantisbt = mantisbt.activationScript;
25 services.websites.env.tools.vhostConfs.git = {
26 certName = "eldiron";
27 addToCerts = true;
28 hosts = ["git.immae.eu" ];
29 root = gitweb.apache.root;
30 extraConfig = [
31 gitweb.apache.vhostConf
32 (mantisbt.apache.vhostConf config.services.phpfpm.pools.mantisbt.socket)
33 ''
34 RewriteEngine on
35 RewriteCond %{REQUEST_URI} ^/releases
36 RewriteRule /releases(.*) https://release.immae.eu$1 [P,L]
37 ''
38 ];
39 };
40 services.phpfpm.pools = {
41 mantisbt = {
42 user = config.services.httpd.Tools.user;
43 group = config.services.httpd.Tools.group;
44 settings = mantisbt.phpFpm.pool;
45 phpPackage = pkgs.php72;
46 };
47 };
48 };
49}