aboutsummaryrefslogtreecommitdiff
path: root/modules/private/monitoring/objects_caldance-1.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2020-01-05 17:08:32 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2020-01-05 17:08:32 +0100
commite820134d38c3b7470ea5112f40a6dc967f039878 (patch)
treef05a5cefe285d060aa0ebf52829bcfcd35549f8b /modules/private/monitoring/objects_caldance-1.nix
parentb22ce4895ef1e9723a02061f7293e528cfbf9754 (diff)
downloadNix-e820134d38c3b7470ea5112f40a6dc967f039878.tar.gz
Nix-e820134d38c3b7470ea5112f40a6dc967f039878.tar.zst
Nix-e820134d38c3b7470ea5112f40a6dc967f039878.zip
Add monitoring host
Diffstat (limited to 'modules/private/monitoring/objects_caldance-1.nix')
-rw-r--r--modules/private/monitoring/objects_caldance-1.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/modules/private/monitoring/objects_caldance-1.nix b/modules/private/monitoring/objects_caldance-1.nix
new file mode 100644
index 0000000..2879124
--- /dev/null
+++ b/modules/private/monitoring/objects_caldance-1.nix
@@ -0,0 +1,57 @@
1{ ... }:
2let
3 defaultPassiveInfo = {
4 use = "external-passive-service";
5 freshness_threshold = "450";
6 retry_interval = "1";
7 host_name = "caldance-1.v.immae.eu";
8 };
9in
10{
11 host = {
12 "caldance-1.v.immae.eu" = {
13 alias = "caldance-1.v.immae.eu";
14 address = "caldance-1.v.immae.eu";
15 use = "linux-server";
16 hostgroups = "webstatus-hosts";
17 _webstatus_name = "caldance-1";
18 };
19 };
20 service = map (s: defaultPassiveInfo // s) [
21 {
22 service_description = "Size on root partition";
23 servicegroups = "webstatus-resources";
24 }
25
26 {
27 service_description = "Total number of process";
28 servicegroups = "webstatus-resources";
29 }
30
31 {
32 service_description = "Average load";
33 servicegroups = "webstatus-resources";
34 }
35
36 {
37 service_description = "Swap usage";
38 servicegroups = "webstatus-resources";
39 }
40
41 {
42 service_description = "fail2ban is active";
43 servicegroups = "webstatus-resources";
44 }
45
46 {
47 service_description = "NTP is activated and working";
48 servicegroups = "webstatus-resources";
49 freshness_threshold = "5400";
50 }
51
52 {
53 service_description = "Databases are present in postgresql";
54 servicegroups = "webstatus-databases";
55 }
56 ];
57}