aboutsummaryrefslogtreecommitdiff
path: root/lib/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /lib/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/lib/default.nix b/lib/default.nix
deleted file mode 100644
index 7b392f1..0000000
--- a/lib/default.nix
+++ /dev/null
@@ -1,16 +0,0 @@
1{ pkgs }:
2with pkgs;
3rec {
4 flakeCompat = import ./flake-compat.nix;
5 nodeEnv = import ./node-env.nix;
6
7 fetchedGithub = path:
8 let
9 json = lib.importJSON path;
10 in rec {
11 version = json.tag;
12 pname = json.meta.name;
13 name = "${pname}-${version}";
14 src = fetchFromGitHub json.github;
15 };
16} // (if builtins.pathExists ./private then callPackage ./private {} else {})