aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2018-12-20 00:09:58 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2018-12-20 00:10:11 +0100
commitd0f8088176b96b41bb7fe5911b9a224883b4b9f1 (patch)
tree2495aa0984e6174c62e5162ede66b9116c86a0cd /default.nix
parent3936ddc576d7e896f5894902bcb19a045709fd6f (diff)
downloadNix-d0f8088176b96b41bb7fe5911b9a224883b4b9f1.tar.gz
Nix-d0f8088176b96b41bb7fe5911b9a224883b4b9f1.tar.zst
Nix-d0f8088176b96b41bb7fe5911b9a224883b4b9f1.zip
Add note taking applications
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 4592eef..c2fe492 100644
--- a/default.nix
+++ b/default.nix
@@ -86,6 +86,42 @@ let
86 }; 86 };
87 }; 87 };
88 88
89 buildPerlPackage = callPackage <nixpkgs/pkgs/development/perl-modules/generic> { };
90 note = buildPerlPackage rec {
91 name = "note-1.3.26";
92 src = fetchurl {
93 url = "mirror://cpan/authors/id/T/TL/TLINDEN/${name}.tar.gz";
94 sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
95 };
96 outputs = ["out" "man"];
97 buildInputs = [ perlPackages.YAML ];
98 meta = with stdenv.lib; {
99 description = "A perl script for maintaining notes";
100 homepage = http://www.daemon.de/NOTE;
101 license = licenses.gpl3;
102 maintainers = with maintainers; [ { name = "T.v.Dein"; email = "tlinden@cpan.org"; } ];
103 platforms = platforms.unix;
104 };
105 };
106
107 terminal_velocity = with python2Packages; buildPythonApplication rec {
108 pname = "terminal-velocity-git";
109 version = "0.2.0";
110
111 patches = [
112 # FIXME: update this patch when version changes
113 ./patches/terminal_velocity_fix_build.patch
114 ./patches/terminal_velocity_sort_found_notes.patch
115 ];
116
117 propagatedBuildInputs = [ chardet urwid sh pyyaml ];
118 buildInputs = [ m2r restructuredtext_lint pygments ];
119
120 src = fetchPypi {
121 inherit pname version;
122 sha256 = "13yrkcmvh5h5fwnai61sbmqkrjyisz08n62pq0ada2lyyqf7g6b9";
123 };
124 };
89in 125in
90 { 126 {
91 inherit nix-prefetch-scripts; 127 inherit nix-prefetch-scripts;
@@ -109,5 +145,6 @@ in
109 inherit ranger; 145 inherit ranger;
110 inherit profanity; 146 inherit profanity;
111 inherit weechat; 147 inherit weechat;
148 inherit note terminal_velocity;
112 #inherit nixos; 149 #inherit nixos;
113 } 150 }