aboutsummaryrefslogtreecommitdiff
path: root/waon/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'waon/PKGBUILD')
-rw-r--r--waon/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/waon/PKGBUILD b/waon/PKGBUILD
new file mode 100644
index 0000000..b1b6947
--- /dev/null
+++ b/waon/PKGBUILD
@@ -0,0 +1,29 @@
1# Maintainer : Immae <ismael.bouya@normalesup.org>
2# Contributor : Ray Rashif <schiv@archlinux.org>
3
4pkgname=waon
5pkgver=0.10
6pkgrel=1
7pkgdesc="Wave-to-Notes transcriber (WAVE-MIDI converter)"
8arch=('i686' 'x86_64')
9url="http://waon.sourceforge.net/"
10license=('GPL2')
11depends=('fftw' 'libsamplerate' 'libao' 'gtk2')
12source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
13sha512sums=('1e3c0ee9cb864c6fbfe831ed5b825fd5f20a8969ef3a6906deb88ceeee9bf8e65396f8b333bc84cf201d596467c415dfcbcd3e977a005952bae2d5983a84fa46')
14
15build() {
16 cd "$srcdir/$pkgname-$pkgver"
17
18 sed -i 's:usr/local:usr:g' Makefile
19 make
20}
21
22package() {
23 cd "$srcdir/$pkgname-$pkgver"
24
25 install -Dm755 pv $pkgdir/usr/bin/waon-pv
26 install -m755 waon gwaon $pkgdir/usr/bin/
27 install -Dm644 pv.1 $pkgdir/usr/share/man/man1/waon-pv.1
28 install -m644 {waon,gwaon}.1 $pkgdir/usr/share/man/man1/
29}