diff options
Diffstat (limited to 'patacrep/PKGBUILD')
-rw-r--r-- | patacrep/PKGBUILD | 26 |
1 files changed, 26 insertions, 0 deletions
diff --git a/patacrep/PKGBUILD b/patacrep/PKGBUILD new file mode 100644 index 0000000..9d56c96 --- /dev/null +++ b/patacrep/PKGBUILD | |||
@@ -0,0 +1,26 @@ | |||
1 | # Maintainer: Immae <ismael.bouya@normalesup.org> | ||
2 | |||
3 | pkgname=patacrep | ||
4 | pkgver=5.1.2 | ||
5 | pkgrel=1 | ||
6 | pkgdesc="Engine for LaTeX songbooks" | ||
7 | arch=('any') | ||
8 | url="http://www.patacrep.com" | ||
9 | license=('GPL') | ||
10 | depends=('python' 'python-ply' 'python-jinja' 'python-chardet' | ||
11 | 'python-unidecode' 'texlive-fontsextra' 'texlive-latexextra' | ||
12 | 'python-argparse' 'lilypond') | ||
13 | makedepends=('python-setuptools') | ||
14 | source=("https://github.com/patacrep/${pkgname}/archive/v${pkgver}.tar.gz") | ||
15 | sha512sums=('1a734e775f3dca4419374fdd9283bd5eed6f8238bac96694e0354cbe4ac6c05f601f5f237a77cda9eed89b95148cbedb108cf810ca5e0fd4e7812408cbdac4f9') | ||
16 | |||
17 | build() { | ||
18 | cd "$srcdir/${pkgname}-${pkgver}" | ||
19 | python setup.py build | ||
20 | } | ||
21 | |||
22 | package(){ | ||
23 | cd "$srcdir/${pkgname}-${pkgver}" | ||
24 | python setup.py install --root="${pkgdir}" | ||
25 | } | ||
26 | |||