aboutsummaryrefslogtreecommitdiff
path: root/patacrep-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'patacrep-git/PKGBUILD')
-rw-r--r--patacrep-git/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/patacrep-git/PKGBUILD b/patacrep-git/PKGBUILD
new file mode 100644
index 0000000..19d0553
--- /dev/null
+++ b/patacrep-git/PKGBUILD
@@ -0,0 +1,31 @@
1# Maintainer: Immae <ismael.bouya@normalesup.org>
2
3pkgname=patacrep-git
4pkgver=5.1.2.r17.g30eb8d62
5pkgrel=1
6pkgdesc="Engine for LaTeX songbooks"
7arch=('any')
8url="http://www.patacrep.com"
9license=('GPL')
10depends=('python' 'python-ply' 'python-jinja' 'python-chardet'
11 'python-unidecode' 'texlive-fontsextra' 'texlive-latexextra'
12 'python-argparse' 'lilypond')
13makedepends=('python-setuptools')
14source=("patacrep-git::git://github.com/patacrep/patacrep.git#branch=master")
15sha256sums=('SKIP')
16
17pkgver() {
18 cd "$srcdir/$pkgname"
19 git describe --long --tags | sed -e 's/\([^-]*-g\)/r\1/;s/-/./g' -e "s/^v//"
20}
21
22build() {
23 cd "$srcdir/$pkgname"
24 python setup.py build
25}
26
27package(){
28 cd "$srcdir/$pkgname"
29 python setup.py install --root="${pkgdir}"
30}
31