diff options
Diffstat (limited to 'nix/PKGBUILD')
-rw-r--r-- | nix/PKGBUILD | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/nix/PKGBUILD b/nix/PKGBUILD new file mode 100644 index 0000000..8005698 --- /dev/null +++ b/nix/PKGBUILD | |||
@@ -0,0 +1,40 @@ | |||
1 | # Maintainer: Alastair Pharo <asppsa at gmail dot com> | ||
2 | # Contributor: Felix Morgner <felix.morgner@gmail.com> | ||
3 | # Contributor: Vlad M. <vlad@archlinux.net> | ||
4 | # Contributor: Mario Rodas | ||
5 | # Contributor: Oozyslug <oozyslug at gmail dot com> | ||
6 | # Contributor: koral <koral at mailoo dot org> | ||
7 | # Contributor: Anders Bennehag | ||
8 | |||
9 | pkgname=nix | ||
10 | pkgver=2.2.2 | ||
11 | pkgrel=2 | ||
12 | pkgdesc="A purely functional package manager" | ||
13 | arch=('i686' 'x86_64' 'armv7h') | ||
14 | url="https://nixos.org/nix" | ||
15 | license=('LGPL') | ||
16 | depends=('gc' 'libsodium' 'boost' 'brotli' 'editline' 'dash-static') | ||
17 | makedepends=('bzip2' 'openssl') | ||
18 | install=nix.install | ||
19 | source=("https://nixos.org/releases/nix/nix-$pkgver/nix-$pkgver.tar.xz") | ||
20 | sha256sums=('f80a1b4f9837a8d33209f0b7769d5038335459ff4303eccf3e9217a9eca8594c') | ||
21 | |||
22 | prepare() { | ||
23 | cd "$pkgname-$pkgver" | ||
24 | } | ||
25 | |||
26 | build () { | ||
27 | cd "$pkgname-$pkgver" | ||
28 | ./configure --prefix=/usr \ | ||
29 | --libexecdir="/usr/lib/$pkgname" \ | ||
30 | --sysconfdir=/etc \ | ||
31 | --with-sandbox-shell=/usr/bin/dash-static \ | ||
32 | --enable-gc | ||
33 | make | ||
34 | } | ||
35 | |||
36 | package() { | ||
37 | cd "$pkgname-$pkgver" | ||
38 | make DESTDIR="$pkgdir" install | ||
39 | install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE" | ||
40 | } | ||