aboutsummaryrefslogtreecommitdiff
path: root/editline/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'editline/PKGBUILD')
-rw-r--r--editline/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/editline/PKGBUILD b/editline/PKGBUILD
new file mode 100644
index 0000000..5865c5f
--- /dev/null
+++ b/editline/PKGBUILD
@@ -0,0 +1,27 @@
1# Maintainer : Immae <ismael.bouya@normalesup.org>
2
3pkgname=editline
4pkgver=1.16.1
5pkgrel=1
6pkgdesc="A readline() replacement for UNIX without termcap (ncurses)"
7arch=('x86_64')
8url="http://troglobit.com/editline.html"
9license=('BSD')
10source=("https://github.com/troglobit/${pkgname}/archive/${pkgver}.tar.gz")
11sha512sums=('32c8362cd553ff616ecbb259705d6ed13a48f5bae0616c9770d9c254e07723bbd957de8ad0643d0652ec73e8e99e8c45e7f060461ba316b0eb30d911d772b029')
12
13
14build () {
15 cd "$pkgname-$pkgver"
16 ./autogen.sh
17 ./configure --prefix=/usr \
18 --sysconfdir=/etc \
19 --enable-gc
20 make
21}
22
23package() {
24 cd "$pkgname-$pkgver"
25 make DESTDIR="$pkgdir" install
26 mv $pkgdir/usr/share/man/man3/editline.3 $pkgdir/usr/share/man/man3/editline-troglobit.3
27}