diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 10 |
1 files changed, 6 insertions, 4 deletions
@@ -4,14 +4,16 @@ | |||
4 | 4 | ||
5 | pkgname=st-git | 5 | pkgname=st-git |
6 | _pkgname=st | 6 | _pkgname=st |
7 | pkgver=20151011.f56c58a | 7 | pkgver=20160309.3996461 |
8 | pkgrel=1 | 8 | pkgrel=1 |
9 | pkgdesc='Simple virtual terminal emulator for X' | 9 | pkgdesc='Simple virtual terminal emulator for X' |
10 | url='http://git.suckless.org/st/' | 10 | url='http://git.suckless.org/st/' |
11 | arch=('i686' 'x86_64') | 11 | arch=('i686' 'x86_64') |
12 | license=('MIT') | 12 | license=('MIT') |
13 | options=('zipman') | ||
13 | depends=('libxft') | 14 | depends=('libxft') |
14 | makedepends=('ncurses' 'libxext' 'git') | 15 | makedepends=('ncurses' 'libxext' 'git') |
16 | # include config.h and any patches you want to have applied here | ||
15 | source=('git://git.suckless.org/st') | 17 | source=('git://git.suckless.org/st') |
16 | sha1sums=('SKIP') | 18 | sha1sums=('SKIP') |
17 | 19 | ||
@@ -36,6 +38,7 @@ prepare() { | |||
36 | -e 's/CFLAGS =/CFLAGS +=/g' \ | 38 | -e 's/CFLAGS =/CFLAGS +=/g' \ |
37 | -e 's/LDFLAGS =/LDFLAGS +=/g' \ | 39 | -e 's/LDFLAGS =/LDFLAGS +=/g' \ |
38 | -e 's/_BSD_SOURCE/_DEFAULT_SOURCE/' \ | 40 | -e 's/_BSD_SOURCE/_DEFAULT_SOURCE/' \ |
41 | -e 's/\(-lXft\)/\1 -lXrender/' \ | ||
39 | -i config.mk | 42 | -i config.mk |
40 | sed '/@tic/d' -i Makefile | 43 | sed '/@tic/d' -i Makefile |
41 | for file in "${source[@]}"; do | 44 | for file in "${source[@]}"; do |
@@ -43,10 +46,9 @@ prepare() { | |||
43 | # add config.h if present in source array | 46 | # add config.h if present in source array |
44 | # Note: this supersedes the above sed to config.def.h | 47 | # Note: this supersedes the above sed to config.def.h |
45 | cp "$srcdir/$file" . | 48 | cp "$srcdir/$file" . |
46 | continue | 49 | elif [[ "$file" == *.diff || "$file" == *.patch ]]; then |
47 | elif [[ "$file" == *.diff ]]; then | ||
48 | # add all patches present in source array | 50 | # add all patches present in source array |
49 | patch -Np1 <"$srcdir/$file" | 51 | patch -Np1 <"$srcdir/$(basename ${file})" |
50 | fi | 52 | fi |
51 | done | 53 | done |
52 | } | 54 | } |