]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blobdiff - lib/default.nix
Remove private specificities from pure-ftpd package and lib
[perso/Immae/Config/Nix/NUR.git] / lib / default.nix
index 1baee1f53e79cea08a6611fc87a28ead8e247520..6b3dfdf47fff4f964ec9ef7ea0cb8152fbcc7b5f 100644 (file)
@@ -61,22 +61,4 @@ rec {
         makeWrapper "$f" "$out" ${toString args}
       '';
 
-  # This adds header colors to the builds, but it rebuilds the whole
-  # world from scratch, so only use it to debug!
-  # add it as postHook in derivations
-  immaePostHook = ''
-    header() {
-      echo -ne "\033[1;36m"
-      echo -n "$1"
-      echo -e "\033[0m"
-    }
-
-    echoCmd() {
-      printf "\033[1;34m%s:\033[0m" "$1"
-      shift
-      printf ' %q' "$@"
-      echo
-    }
-  '';
-
-} // (if builtins.pathExists ./lib/private then import ./lib/private else {})
+} // (if builtins.pathExists ./private then callPackage ./private {} else {})