]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blob - pkgs/terminal-velocity/default.nix
Initial commit published for NUR
[perso/Immae/Config/Nix/NUR.git] / pkgs / terminal-velocity / default.nix
1 { python36Packages }:
2 with python36Packages;
3 buildPythonApplication rec {
4 pname = "terminal-velocity-git";
5 version = "0.2.0";
6 src = fetchPypi {
7 inherit pname version;
8 sha256 = "13yrkcmvh5h5fwnai61sbmqkrjyisz08n62pq0ada2lyyqf7g6b9";
9 };
10
11 patches = [
12 ./sort_found_notes.patch
13 ./python3_support.patch
14 # FIXME: update this patch when version changes
15 ./fix_build.patch
16 ];
17
18 propagatedBuildInputs = [
19 chardet
20 urwid
21 (sh.overridePythonAttrs { doCheck = false; })
22 pyyaml
23 ];
24 buildInputs = [
25 m2r
26 (restructuredtext_lint.overridePythonAttrs { doCheck = false; })
27 pygments
28 ];
29
30 postInstall = ''
31 rm $out/bin/terminal_velocity
32 '';
33 }