]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blob - pkgs/telegramircd/default.nix
Initial commit published for NUR
[perso/Immae/Config/Nix/NUR.git] / pkgs / telegramircd / default.nix
1 { openssl, telethon, python3Packages, mylibs }:
2 with python3Packages;
3 buildPythonApplication rec {
4 format = "other";
5 pname = "telegramircd";
6 version = "master";
7 propagatedBuildInputs = [ telethon aiohttp ConfigArgParse openssl ];
8 src = (mylibs.fetchedGithub ./telegramircd.json).src;
9 LD_LIBRARY_PATH = "${openssl.out}/lib";
10 installPhase = ''
11 install -D $src/telegramircd.py $out/bin/telegramircd
12 wrapProgram "$out/bin/telegramircd" \
13 --prefix LD_LIBRARY_PATH : "${openssl.out}/lib"
14 install -Dm644 "$src/config" -t "$out/etc/telegramircd/"
15 '';
16 }