]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blob - pkgs/notmuch/notmuch-python/default.nix
Initial commit published for NUR
[perso/Immae/Config/Nix/NUR.git] / pkgs / notmuch / notmuch-python / default.nix
1 { stdenv, notmuch, pythonPackages }:
2 stdenv.mkDerivation rec {
3 name = "notmuch-${pythonPackages.python.name}-${version}";
4 version = notmuch.version;
5 outputs = [ "out" ];
6 buildInputs = with pythonPackages; [ sphinx python ];
7 src = notmuch.src;
8 phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
9 buildPhase = ''
10 cd bindings/python
11 python setup.py build
12 '';
13 installPhase = ''
14 python setup.py install --prefix=$out --optimize=1
15 '';
16 }