]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blob - overlays/environments/immae-eu.nix
1f27e7cae5f885200d5d1ad96b01b61abad27d4c
[perso/Immae/Config/Nix/NUR.git] / overlays / environments / immae-eu.nix
1 self: super: with self;
2 let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 p7zip xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncer pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
20 cardano sia monero
21 xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
26 rr valgrind netcat-gnu strace
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
34 neomutt mairix notmuch
35 bogofilter fetchmail
36
37 # git
38 vcsh gitRepo gitAndTools.stgit tig
39
40 # graphical tools
41 nextcloud-client firefox
42 dwm dmenu st
43
44 # images
45 feh imagemagick tiv graphicsmagick
46
47 # internet browsing
48 w3m lynx links elinks browsh weboob urlview googler urlwatch
49
50 # less
51 python3Packages.pygments lesspipe highlight sourceHighlight
52
53 # monitoring
54 cnagios mtop pg_activity nagios-cli mtr
55 iftop htop iotop iperf
56 goaccess
57 # nagnu
58
59 # messaging/forums/news
60 flrn slrn
61 telegram-cli telegram-history-dump telegramircd
62 weechat profanity
63 newsboat irssi
64
65 # nix
66 mylibs.yarn2nixPackage.yarn2nix
67 nixops nix-prefetch-scripts nix-generate-from-cpan
68 nix-zsh-completions bundix nodePackages.bower2nix
69 nodePackages.node2nix
70 # (nixos {}).nixos-generate-config
71 # (nixos {}).nixos-install
72 # (nixos {}).nixos-enter
73 # (nixos {}).manual.manpages
74
75 # note taking
76 note terminal-velocity jrnl
77
78 # office
79 sc-im ranger
80 genius bc
81 ledger
82 tmux
83 rtorrent
84 ldapvi
85
86 # password management
87 pass apg pwgen
88
89 # pdf
90 pdftk poppler_utils
91
92 # programming
93 pelican emacs26-nox ctags
94 wdiff
95
96 # security
97 keybase
98
99 # todolist/time management
100 taskwarrior vit timewarrior
101
102 # video/music
103 youtube-dl ncmpc ncmpcpp ffmpeg
104
105 # other tools
106 pgloader s3cmd lftp jq cpulimit libxslt
107 ];
108 in
109 {
110 myEnvironments.immae-eu = buildEnv {
111 name = "immae-eu-packages";
112 inherit paths;
113 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
114 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
115 };
116 }