]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blob - overlays/databases/postgresql/default.nix
Initial commit published for NUR
[perso/Immae/Config/Nix/NUR.git] / overlays / databases / postgresql / default.nix
1 self: super: rec {
2 postgresql_11_custom = super.postgresql_11.overrideAttrs(old: {
3 # datadir in /var/lib/postgresql is named after psqlSchema
4 passthru = old.passthru // { psqlSchema = "11.0"; };
5 configureFlags = old.configureFlags ++ [ "--with-pam" ];
6 buildInputs = (old.buildInputs or []) ++ [ self.pam ];
7 patches = old.patches ++ [
8 ./postgresql_run_socket_path.patch
9 ];
10 });
11 }